"No fix to satellities" Issue on Qstarz BT-Q1000eX 10hz

Need help right away because I have race in next two days. I get the No Fix to Satellites error and have tried everything I have read (I even bought a brand new unit, as I have been using Qstarz and Qracing for last 2 years). I have Samsung Galaxy S6 and latest version of RaceChrono Pro v4.1.5 I have tried turning on and off the Bluetooth Fix in expert settings. Qstarz device is picking up satellites because the orange satellite icon is flashing. Background info: 1) devices pair, 2) in setup - external GPS is selected & Qstarz 1000ex is device & Use for Recording is checked, 3) Bluetooth is connecting, 4) I am getting same issue on my older Samsung Galaxy S4

Please advise.


  • OK. Please do following:

    1) Enable "RaceChrono > Expert settings > Save device output"
    2) Record one session with the GPS. Make sure the GPS seems to get proper lock to satellites (by looking at the LEDs).
    3) Go to /RaceChrono/session_(date)_(time)/ folder on your phone. There should be device_x_output.nmea file.
    4) Send the output file to tracks(at)racechrono.com

    I will take a look.
  • Thanks for fast response. File sent to email as requested.
  • aolaol
    edited June 2015
    Problem is that the GPS is only outputting RMC sentence. RaceChrono needs a combination of at least RMC and GGA. MTK-II chipset (and most others too) has had RMC/GGA/GSV/GSA enabled as default in the past. I wonder if you are using some other GPS software that configures it? Can you list the other apps you use with this GPS if any?

    Maybe it's time to re-enable my automatic MTK-II reconfiguration code... It was disabled due to some bluetooth problems, but maybe it could be enabled only when there's missing sentences.

    The GPS comes with software that can be used to configure these sentences, and you can fix the issue temporarily by using it to re-enable RMC and GGA. I'm more interested if this is default behaviour on new devices or if it's some other app playing with the configuration.

  • See email response I sent because I had to include image attachments. THX.
  • aolaol
    edited June 2015
    The MTK configuration code is not something I can turn on quickly. I have to write some new code, test it and include it in a future version of RaceChrono.

    There is an MTK utility app that you could try for enabling the GGA and RMC sentences:


    You could try the "Default NMEA" button or if that does not work then set "GGA" and "RMC" to 1 and save settings at this page:


    You should end up seeing other sentences besides $GPRMC. It and $GPGGA are required, $GPGSV and $GPGSA do not hurt either.
  • Just set GCA & RMC to 1, will try this evening. Just to let you know that RaceChrono is the only software I use with my Qstarz and don't remember I did any change on it for ages.
  • Also one thing to notice is that _most_ of the data will still get recorded even without the GGA sentence. The UI complains about "no fix to satellites", but the data will actually get recorded anyways. Bearing, Speed, Position and Time/Date will get recorded, but Altitude, DOP values etc will not.
  • Hi, was this ever modified in the main app? I've struck the same issue on the latest DStarz and ended up at this thread.
  • It was never added, so you'll need to modify the sentences through the application on Windows PC.
Sign In or Register to comment.