iOS video not loading

I'm trying to load a video file from the photos app into the session but all I get is a spinning icon. Screenshot here https://s12.postimg.org/jgis6n5j1/IMG_0135.png

Comments

  • The problem might be that the player doesn't support this particular video file. Can you share this file to me somehow (DropBox, Google Drive, etc..) so I can take a look? You can send the share link to tracks(at)racechrono.com .

    Typically most action cameras produce video files that are supported, but if the video has been post processed with a video software on computer, it might turn to a format not supported.
  • Ok I will send you a link.

    I am using a GoPro Hero4 originally set to 1080/50 but suspected this could be a problem. I also tried transcoding it to 720/30 using handbrake but that didn't work either.
  • aolaol
    edited April 2017
    @ash 1080p50 from GoPro HERO 4 should work just fine. Not sure if on all of the devices though, I'll need to test that.

    How did you move the video to Photos app? Was it in iCloud or on the device? Which device model and iOS version is it? Asking for to able to reproduce the problem.
  • Im having a bad time uploading this file. While I continue can you tell me what the limitations of the player are please? What is the best format and encoding to use?
  • The limitations are the phone limitations for playback. So mpeg/h264 video with AAC audio in mp4 or mov container will work. But the HERO 4 native format already matches this, so I would need to know your device model and iOS version for checking any limitations for fps and resolution.
  • I've solved it.

    It's not a bug but a quirk with how video is loaded in the iOS Photos app. It doesn't actually download the video to the device even though it appears so. It seems to be some kind of progressive download, to save space on the device I suppose? I had imported it into the photos app on my Mac and left iCloud to sync it to the iPad.

    To find the solution I wanted to shorten the video in case it was a lie issue, so I pressed the edit icon in the photos app, at which point the app then downloaded the whole video. I had a good feeling that this could be it and once completely downloaded I then returned to RaceChrono and selected the video again. It immediately showed and I could link it.
  • aolaol
    edited April 2017
    Thank you for the information. I'm guessing it probably tried to stream the video over internet (hence the loading animation), but your bandwidth was already occupied by the download. Also the streaming of GoPro 1080p50 video would require serious bandwidth.
  • Yes exactly right. This weekend will be 720p30 to make everything easier.
  • aolaol
    edited April 2017
    @ash here's good reference about GoPro HERO 4 bitrates. Apparently you won't save that much by 720p30 https://gopro.com/support/articles/hero4-black-recording-time-in-each-video-setting
Sign In or Register to comment.