Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

OBD behavior

Hi,

I am developing a custom interface that emulates an OBD interface, and I'm trying to make racechrono work with it. (https://github.com/fpoussin/MotoLink)

I've tested the said interface with a couple scantool softwares, it worked fine.
I've also tested the adapter (ELM327 via BT) on my car with racechrono and it worked fine as well.
So I know both my adapter and my interface are working.

When using the adapter on my interface I only get requests on PID 0 (which are answered) and the message "waiting for data..."
I never get the requests for the PIDs I selected. (TPS, etc)

I am wondering what kind of data racechrono is expecting.
Thanks.

Comments

  • It's expecting array of supported PIDs, look at https://en.m.wikipedia.org/wiki/OBD-II_PIDs . Just return FF FF FF FF, which states all PIDs are supported. Do same for PID 20 etc.
  • I did try to reply FF already but it did not make any difference compared to the normal answer (I reply a proper list of supported PIDs)
    It keeps asking for PID 00 only.
  • aolaol
    edited May 9
    Well other reason could be you have no channels selected in RaceChrono. But there's no other magic to it.
  • I did try to add, remove, then add back some channels, it made no difference.
    Which supported PIDs is it expecting from PID 00?
    Maybe I missed something, I'll run some more tests.
  • aolaol
    edited May 9
    It's expecting the ones that you have selected. It will not request anything that is not supported according PID 00, PID 20 etc. If nothing of the selected channels are supported it will just keep requesting PID 00, PID 20 etc in a loop.

    I suspect you got the bit order wrong or something, so it thinks the ones you selected are not supported. Or the response format is not correct. You can also adjust the expert settings to ignore this PID, so it will request the ones you selected anyways.
  • I'll try to disable it to confirm it's causing this behavior, then re-enable it and fix it.
    Thanks!
  • Went to the experts settings to disable it, it did not change anything, still only asking for PID 00.

    This is the traffic I see on the CAN bus:
    ->[SID:7DF][RTR:0]:02:01:00:00:00:00:00:00
    <-[SID:7E8][RTR:0]:06:41:00:10:18:80:01:00
  • I found the issue after testing the ELM adapter directly, which was my fault: the DLC field was too short.
    All good now. Thanks!
Sign In or Register to comment.