RaceChrono v1.21 beta for Windows Mobile known issues

Version 1.21 beta 3:
    [li]IMPROTANT: If you're having problems with installation, there one common thing to go wrong. Please use "save as file" when clicking the download link, so you save the .CAB file to your disk instead opening it. Then copy the .CAB file to your device and open it there. [li]IMPORTANT: The windows GPS API is not supported. This means to use the internal GPS, you need to define a COM: port for it. Go to "Settings (Windows) > External GPS > Programs" and select a port in "GPS program port". Then go to RaceChrono settings and select the same port you just defined. [li]Input panel selection icon shows up after switching back to RaceChrono from an another software. [li]Number editors accept text as well [li]Bluetooth on MotoQ is not supported, as this phone does not use Microsoft Bluetooth stack. Configure your GPS and RaceChrono to use a COM: port instead. [li]Not able to select additional storages on some 5.0 devices. Anyone else experiencing this? [li]The program does not start on one HTC Touch Cruise (WM 6.1) phone, but starts in other similar phones. Does anyone else have this problem? [li]Loosing editor focus when coming back from another applications (WM std) [li]Performance testing does not work on some Internal GPS, because they report no speed when stationary. [li]Issues with progress dialogs when connecting to Bluetooth devices.


  • Hi, I am from Italy,
    replaying to question #10, I installed beta version on my HTC Cruise and works very well (with external GPS, of course).
    Many thanks for your work!
  • Thank you for the report! I think it's a problem in a particular phone then.
  • Updated list to reflect v1.21 beta3. See changes from a recent blog post (in news section of this web page).
  • edited April 2009
    hi aol.

    still have issue no.5.

    It allows me to select "\Storage Card" at instllation but not in the RaceChrono settings. Only "My Documents" is available indicating 11224KB remaining.

    File manager shows the file system path for the devices my documents folder:
    smartphone\My Documents
    path for the additional storage my documents folder:
    smartphone\Storage Card\My Documents

    MS Windows Mobile 5.0 (5.1.195 build 14847.2.0.0)

  • Hi Mike, thanks for reminding! I will contact you via email!
  • I've downloaded RaceChrono onto my palm treo pro windows mobile 6.1 pda/phone. I can set up the GPS and RaceChrono can see my car is moving and can log data.

    BUT I when I move to performance test (not near a track yet) I cannot seem to start the test. On the manual it says hit the start button - but there isnt one!!
  • Sorry, there isn't a start button. The performance test will be ready start when the GPS speed is near 0 for some time. When you start moving, the time will start running.
  • How much time, I tried up to 5 minutes - I'll try again today.
  • edited April 2009
    10-15 seconds should be enough. Maybe you are having some GPS problems. Are you using a internal GPS or external bluetooth GPS? Does the 80-120 kph test work?
  • Not tried the 80-120 - internal GPS.

    On the "classic look" for the performance meter I can see its detecting speed, altitude, direction, and logging data.
  • Does the speed go zero, and/or does it show NO DATA?

    The internal GPS's are generally not recommended for performance testing, because the results are a bit unreliable. But if you sill want to use it, it is very important to keep the phone so that there is a direct view to satellites: place the phone to the dash board near the windshield (in a car, bikes are a bit easier).

    Can you send me NMEA data from your test tries? Find the files from under selected storage (for example \Storage card\RaceChrono\Sessions\*-nmea.txt). Send them to me to tracks(at)racechrono.com.
  • I'll try another test today and send you the data.
  • 50-80 mph time works fine.....

    GPS says NO DATA when stationary.
  • All right, I think that's the problem then... Thanks for the data and the bug report, I will try to sort the issue out for next beta release!
  • I tried 0-100 at the weekend. Seemed to work fine.

    Took me a while to find the option to export the performance data. I thought it would be in the menu displaying the run times (becuse that's where it is on the lap timing sessions) but eventually found it in Travelled Route.

    Have been unable to export VBO, KML or CSV. Error #5. This is only occuring on the Performance Tests. Data logging and lap timing export fine.

    This is using the WM 5 build that supports the storage card. I've tried with the storage card as the selected device and with internal storage as the selected device.

  • Thanks for the report Mike, I'll take a look at that as well.
Sign In or Register to comment.