Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Video Sync

I try to synchronize with Race Chrono PRO a data session and a video taken at the same time as the session but with an external cam (not a GO Pro).

I can not synchronize the two and when I launch everything, the session scrolls but the video does not move ...

Can someone bring me help or ideas ???

Thanks in advance :)

Comments

  • aolaol
    edited July 2018
    RaceChrono uses the Android system video player, so when you have playback issues like this, it usually means the video file is not properly supported by Android.

    1) If the video file did not come directly from the camera, but you did some processing to it, try the raw file.

    2) You can try to re-encode the file on PC with ffmpeg like this: ffmpeg -i input.mp4 -vcodec libx264 -acodec aac output.mp4

    3) Also your video might be too high resolution / bit rate / fps for your phone. For example 4K 60 fps video will need a very modern phone to be able to playback.
  • The phone is a Xiaomi Redme 4X and the file is in 1080p (made with an external Cam, the phone cam is too crap). The file is read with no prob in the phone video player but not in Race Chrono.

    In Race Chrono its just possible to move in the file but the continu read dont work.
    But if i generate the new .mp4 file (data+vidz) in Race Chrono, the new generated file with the incrustation is properly read with the phone video player.

    So the synchro in the new file is not really good. There is a lag between the engine sound and inlays of revolutions / min Engine... I can not make disappear this discrepancy ? how can I do it?

    And why there is a writing RACECHRONO PRO at the bottom left of the image that is added in the new file ??? I do not want this writing, we paid the software and we have to advertise ???
  • aolaol
    edited July 2018
    The phone video player is different than Android video player, so there might be difference.

    I don't quite understand what is exactly the problem. So the video partly works but partly doesn't? Can you explain or take a video or something?

    The RaceChrono Pro text is about branding. If it was to advertise it would be much bigger :)
  • Explaining something in a language that is not the language one speaks to someone whose native language is not the same is very complicated ...

    So I start again:

    1 - Directly in Race Chrono impossible to play the video. The image remains fixed. The data scrolls, the incrustations of the counters move (needles, numbers ...), the graphical curves also but not the video which remains fixed ...

    2 - So that the video moves with the incrustations I must generate the new MP4 file. Once the new mp4 file created by Race chrono done, I can read it with my phone, the image moves with the incrustations but the timing of 2 is bad. There is a delay (lag) that I can not seem to remove.

    3 - It is totally abnormal that you force people who have paid your software to put your logo. Everyone must be able to do what they want and personally this logo I do not want it. It's up to you to put a function in the software so that we choose to put the logo or not. You do not respect the choice and the life of your users by obliging them, I am dissatisfied and not happy about that.
  • aolaol
    edited July 2018
    1 - I believe there's something wrong with the video - some incompatibility. Which camera is it? Maybe try to re-encode it, before moving to your phone, using ffmpeg on command line: ffmpeg -i input.mp4 -vcodec libx264 -acodec aac output.mp4 . It's available for Windows, Linux, Mac etc..

    2 - Once the video starts moving (fix point 1), you can adjust the sync in RaceChrono. The lag is caused because the video and the data is not syncronized properly.

    3 - Would you be prepared to pay 50 euros for the app if it didn't have the branding?

    4 - If you record video using your integrated camera, does that playback normally in analysis? If so I think it confirms point 1.
  • aolaol
    edited July 2018
    Also if you like, you can share me a sample video, that is confirmed not to work on your phone, to tracks(at)racechrono.com . Probably best to share it through DropBox or similar, as my email only takes files up to 20 mb or so. IF I can replicate the problem, I can confirm a re-encode command that works guaranteed.
Sign In or Register to comment.