Not able to connect gopro hero 3+ black on latest version


I've been using racechrono for quite a while now and took a break from racing for a year and half, just prepping to go back to track when doing a dry run setup I was unable to get my gopro to be detected by racechrono. This used to work on older version of racechrono and no new version of gopro hero 3+ firmware was released since last time I used it so I can only conclude it must be either a racechrono issue or an issue with my phone.

I followed the tutorial and racechrono gets stuck on searching\connecting, but never successfully connects.
Both the gopro app, and navigating directly to works so I am not sure what's the issue. This happens regardless if I am already connected to gopro on wifi. Actually racechrono does correctly connect to the gopro wifi if it's not already connected but still never able to connect to the device after wifi is connected.

I am on Pixel 1 XL, android 9.0 feb 2019 patch. Racechrono v5.5.1
Any help is appreciated.


  • edited February 2019
    Try removing the camera from RaceChrono settings, and then add it again, but this time disable the "Connect Wi-Fi automatically". Then manually switch to the camera Wi-Fi when using the camera with RaceChrono.

    If that works, you can then remove it again from RaceChrono settings, and add it with the automatic Wi-Fi connection enabled. Then "Forget" the camera Wi-Fi network from Android's Wi-Fi settings. Then try again to connect with RaceChrono.

    The automatic Wi-Fi connection from an app is a mess in Android (also in iOS...), and the other apps (like the GoPro app) can interfere with it making it not work at all... This is why I ask to try without it first, to see if it's causing the malfunction.
  • Unfortunately the behavior is the same when I tried those steps.

    I also dug up my old phone which has race chrono pro 4.7x installed, it still worked fine. Unfortunately the phone bit the dust after this weekend of racing so I am not able to update it to the latest racechrono to see if it still worked.
  • edited February 2019
    @sloppyjoe , I've tested with my GoPro 3+ and it works perfectly with my Google Pixel 2 with Android 9.0 (feb patch).

    As I didn't find a bug, all I can do is to give some more check lists:

    1) Remove battery from your GoPro and re-insert it, to make sure it is cold started
    2) Make sure you added the camera with "GoPro 3 / 3+" to RaceChrono settings. Anything else won't work. Make sure you enter the password correctly. Also disable the "Connect Wi-Fi automatically" option.
    3) Enable "RaceChrono > Settings > Expert settings > Save debug logs"
    4) Make sure you're connected to the camera Wi-Fi
    5) Disable mobile data (this should not matter, but just to make sure, for this test)
    6) Start new session
    7) Switch to camera preview page, and see if it connects. Wait for a while if it does not.
    8) Stop the session, wait a minute for the log file to flush.
    9) If it still did not connect, please send me the log file. There should be a file /Android/data/ in internal storage. Please send that to me tracks(at) , or simply copy paste it here.

  • edited March 2019
    Yep, certainly seems a problem, judging by the logs you sent. My guess is this is something to do with stricter network access in Android 9. I'll need to test all my Android 9 devices in hope reproducing the problem. Cannot fix it before I manage to reproduce it unfortunately.
Sign In or Register to comment.