Racechrono does not record laps and does not find location

So recently I am having the following problem with the app.

I am using the Racechrono Pro version of the app and a holux GPSlim 236 bluetooth gps.
The problem is that Racechrono connects to the GPS and shows good connection with between 5-11 satelites connected but in the app it does not show my location and does not suggest a nearest circuit for selection before a session.
When i manually select the track I am at it will sometimes record a lap or a few but most of the time it will not record anything.
I installed a random app from google that uses external bluetooth gps for location and it shows my location perfectly in that app. It is just that racechrono is not showing it. I have tried with another GPS like Holux RCV3000 and still no success. I have deinstalled and installed the app a few times and again no success. Any info would be greatly appreciated.
I can attach screen pictures also if you tell me how to do it.


  • edited September 2019
    Can you do following:

    1) Setup RaceChrono to be used with the external GPS (from RaceChrono settings)
    2) Enable "RaceChrono > Settings > Expert settings > Save device data"
    3) Start new session
    4) Wait until it shows good connection, and maybe 5 minutes more
    5) Stop the session
    6) Share the recorded session to tracks(at)racechrono.com
    7) Repeat with both GPS

    This will allow me to see if there's some kind of incompatibility.
Sign In or Register to comment.