Installation problem on Nokia N-gage second gen

Will this work on the new model N-gage? I get an error on install that the program needs an ID. Thanks for any help.

Comments

  • Sorry, S60 first edition is not supported. This means N-Gage, N-Gage QD, 7650, 3650, 3660, 3620, and 3600.
Sign In or Register to comment.