RaceChrono Won't Let Me Select External Storage

I just downloaded and paid for the full version of RaceChrono and when i try and record video it wont let me select external storage. Using Samsung Galaxy S7 Edge.

I am entering an event in less than 12 hours. Can anyone help?


  • When you open the camera configuration box (in live preview page), does it not let you select between "Internal storage" and "External storage"?

    Make sure your memory card is formatted and mounted correctly in your phone. I don't have S7 Edge to test, but haven't heard before any problem with this.
  • It worked on the regular RaceChrono but when I paid for the Pro version it won't let me select external (it's shaded grey)
  • It should not be any different between versions (=same code). Not sure what's going on...
  • aolaol
    edited December 2017
    Maybe go to edit permissions for RaceChrono Pro app, and check if any of the permissions are disabled
  • Ok I found the issue. I had RaceChrono and RaceChrono Pro installed. Deleted RaceChrono and problem solved!

    Quick question though, when arriving at the start line on a track does it automatically start recording or not ?
  • Thanks for your help by the way :)
  • You need to manually start video recording. I prefer not to start recording on start line, but "start recording on movement" feature is coming
Sign In or Register to comment.