Lap times seem to be 20s slow compared to IR based timer


Was at track for 3 days last weekend and thought the times in RaceChrono were slow compared to what I usually did. It worked flawlessly in the past but this year I have changed pretty well everything about the configuration. I have a buddy who runs Race Chrono on his bike but also brought his old IR based timer and we compared the 2 (he uses BT-Q818XT sensor to phone) and they were within .23 second of each other.

When I added the IR sensor to my motorcycle (I didn't write down the IR times to more decimals so just comparing to the second)

Session IR sensor best lap time of 2:54. Looking in Race Chrono I see best lap of 3:16
Next session IR sensor best time 2:44. Race Chrono best lap 3:03
Last session of day IR 2:45. Race Chrono 3:04.

Interestingly the delta between the times seem to be relatively consistent. When I went 1s slower by IR I was also 1s slower by RC.

The first session above I also have video for. 2nd full lap was my fastest IR and RC. In my video pausing at start/finish I start the lap 14:14:13 local time and I finish it 14:17:08 which is pretty close to 2:54 of the IR timer (within what I can time in video). But is quite a bit from 3:16.06 RC is showing as my fast lap

@aol Looking for thoughts on what might cause this? Or at least what to try to pinpoint things.

Configuration for RC:
- NavSpark GPS sensor (
- NMEA GPS brought into a Teensy 3.6
- add RC3 lines to output (have not moved to binary yet as have not debugged code yet and track season started)
- BT out to RC on Android phone
- Race Chrono 6.0.10
- Android 9 on a BlackView 5500Pro rugged phone from Aliexpress

In my 'drive around the block' testing it worked fine for location but I never tried to time it. But even when I look at the GPS data in RC it shows me going around the laps and the speeds etc look right (what I would expect in the different areas) just the times seem to be 20s +/- off

Thanks, Jeff


  • aolaol
    edited July 2019
    My guess is that time is moving backwards on your setup. RaceChrono tries to compensate that, as it's a known bug on some GPS receivers. It should be quite visible, as it has to go back a lot, or a little bit many times, to make 22 seconds per lap.

    Turn on the "Settings > Expert settings > Save device output", and record a session. Once the session is recorded you can share the .rcz file to yourself. Rename it to .zip and unarchive. There you can find raw output from the device and if I'm right, then you'll find that the time moves backwards between some sentences.

    Even if one sentence is 145522.600 and next one is 145522 without decimals, RaceChrono thinks time moves backwards and tries to compensate.
  • @aol thanks, will look. I enabled the device output once I started seeing things acting weird but didn't know what to look for in the data. Will start there.

    I have my old GPS module as well which worked for 2 years without issue. This new one is just smaller and seemed to lock to GPS and give better location data.

    Will report back once I have some data analysis results.
    Thanks, jeff
  • @aol will RC3 lines also effect this? My GPGGA and GPRMC all seem to be in order. Or at least the ones that I found that are messed up did not have valid checksum so I assum they are ignored (malformed nmea line due to buffer issues)

    But I found that there are bunch of RC3 output I am doing where I somehow flip the lines. So a .700 timestamp followed by a .680 then a .720

    Will work on sorting that ordering out anyhow but wasn't sure what algorithm RC uses and if RC3 would effect it.

    Thanks, Jeff
  • aolaol
    edited July 2019
    I don't know to be honest. Would need to test it I guess. I can run your NMEA file through my parser if you send it to me via email.
  • I started having similar problems
    I have been using RaceHrono for many years. Originally there was a BT-Q818XT sensor. Late Glo. I recently bought the BT-Q818XT again.
    I got strange problems with lap times.
    You can see the results here:
    Tell me what to do?
  • aolaol
    edited September 2019
    @x3m_ded: Yep, seems weird. I'm guessing some kind of problem with the NMEA data again. Usually this would happen when NMEA time moves backwards mid lap.

    Turn on the "Settings > Expert settings > Save device output" for your next track day. Then when you encounter this happening again, share me the session (.rcz file) and the "official" timing sheet to tracks(at) . From there I can analyse the NMEA and possibly fix this.
  • Clear. Thanks for the help. Unfortunately, I will be on the track with official telemetry only next year.
    I turned on Save device output.
    Will device_output.nmea be saved additionally now? Did I understand correctly?
  • Yes, it will be inside the .rcz archive when you share the session.
  • BTW, the issue by the original poster in this thread was indeed NMEA time moving backwards.
  • How to fix the problem by the original poster?
  • He was using a DIY device, he needed to fix the firmware.
  • @x3m_ded I had GPS NMEA sentences as well as RC3 sentences coming over BT. Around the full second point I would often have RC3 and GPS lines in wrong order due to how I was determining the timestamps. I had to add some extra logic to make sure I do second roll-over correctly and make sure output is in properly order

Sign In or Register to comment.