Unable to connect to OBDLink LX

My old china OBD reader did not work with RaceChrono so I ordered a brand new OBDLink LX. The reader arrived today and I just went to try it out. It works perfectly with the OBDLink app. I also tried torque pro which is also working flawlessly. Next I tried to pair the adapter to RaceChrono pro but it did not show up in the list of available devices (of course the adapter was in pairing mode). I tried a factory reset on the adapter without any result. I also noticed that the firmware was old (4.5.1) and I updated to the latest version 4.6.1 but I still don't get a connection. The model number on the label is LX101, manufacturing date is 2019.11.24. What am I missing?

Comments

  • aolaol
    edited February 27
    @Tiger99

    RaceChrono does not show the already paired devices (something to fix in the future I guess) like the other apps. RaceChrono shows the current devices in range when searching.

    So basically you'll need to press the pairing button on the reader again, for it to show up in the search box.

    Also notice you'll need to have the internal GPS enabled on some phones, in order to the Bluetooth search to work.
  • Thanks for your quick reply. I did press the pairing button and the bluetooth light was flashing rapidly. But internal GPS was off, I will try this next.
  • ...turning on internal GPS did the trick :smile:
  • I had the same issue.
    In "General Expert settings" I've enabled "Bluetooth fix", this helped to use OBDLink LX and my external GPS sensor (Q-Starz) at the same time.
    Regards, Roland
  • I've fixed this issue for next version. It will allow selecting from already paired devices, and will complain if location is disabled when searching.
Sign In or Register to comment.