RC not saving sessions if external GPS is used

Hi! I'm using RC Pro ver 6.4.1

Hadn't used it for a while but yesterday I finally made it to the track and it was competitive event so I didn't had much time to troubleshoot.

I had both of Bluetooth gps devices that I used previously with me - old ibt i+ 747 and newer qstarz 818. Both were configured to run 5 hz.

After first session on track with qstarz I noticed that I can't find it in sessions list, although predictive timing was working perfectly fine during the session. I tried to figure out the issue and found that sessions are not saved if I use either of external GPS units. I tried to factory reset one of them to 1hz mode but result was still the same. Internal gps works fine and sessions were saved correctly.

Any thoughts on where should I start with this?

Comments

  • This is a common issue. The session list is sorted by date, and your GPS are suffering from WNRO bug, that started affecting some GPS receivers last year. You'll probably find your sessions at bottom of the list, with dates 2000 or 1999. Instructions how to fix or workaround this issue: https://racechrono.com/article/faq/racechrono-displays-date-that-is-20-years-back

  • Well I was hoping it isn't something from FAQ, but I could feel that it might be something like that...

    Session are at the bottom of really long list, dated 2000...

    Thank you!

Sign In or Register to comment.