Video file names not resolved from GoPro 10

I have GoPro 10 paired with RaceChrono. I am using RC to start and stop video recording when recording sessions. However after session recording is completed, I am not able to resolve linked video files names from camera.

Here is a video where I go through camera connection process which is successful, but video file names are not resolved: https://photos.app.goo.gl/BozsoB8KTy8QFdKM8

Using RaceChrono 7.4.4.

Not sure what information RC is using to resolve video file names from the camera. But the video for lap 2 of the session visible in the screen capture is called "GX010023.MP4" and the date time of the file as seen on the GoPro Quick app is "2/20/22 8:44:04 AM GMT +02:00".

Comments

  • aolaol
    edited February 23
    Workaround If the filename resolving fails: First import (or download) the related video files to RaceChrono. Then go to your sync point (with unresolved name), select the context menu from the right hand side, and select "Rename". Write the name of the video file there. Notice you'll need to have the first chapter's filename there, "GX01xxxx.MP4", "GH01xxxx.MP4" or "GOPRxxxx.MP4". If the name is correct, you will see the video thumbnail.

    RaceChrono tries to resolve the filenames according the timestamps on the memory card. Problem is GoPro updates the timestamps differently depending on the firmware version, camera model and the sun spots. This changes all the time and I'm rather fed up fixing it...

    ... So instead of fixing it, I will remove the filename resolving code on the next major release, and will require users to choose the correct files from the camera. I will add some automation magic to make it easy for the user.

    I think this will be much better for everyone involved :smile:
  • > Problem is GoPro updates the timestamps differently depending on the firmware version, camera model and the sun spots.

    That I have experienced before. :) Where downloaded photos have correct timestamps and downloaded videos have timestamps offset by the time zone offset. Very annoying when uploading all GoPro footage and seeing videos out of sync with photos. Been chatting with GoPro support about this, but did not find a resolution back then.

    With GoPro 10, it "seems" that they have fixed it. Did not notice this faulty behaviour yet.

    > So instead of fixing it, I will remove the resolving code on the next major release

    Yup, sounds good to me. :)
Sign In or Register to comment.