OBDLink LX not sending RPM

Hi,
I have purchased the OBDLink LX adapter and paired with my device (Android 10 Head unit). Several OBD apps (i.e. the OBDLink app itself) receive all car data including engine RPM.
I paired the OBDLink to RaceChrono (Pro, v.7.5.2) and I see it receives data from a handful of channels (throttle pos, temps etc. - haven't dug deep into custom PIDs so far) except for RPM, the indicator remains empty.
What bugs me is that with a low budget "no brand" WiFi OBD adapter I get RPM straightaway.
Looks like the "link" between RaceChrono and OBDLink LX isn't perfect.
I will try to rollback app version, in the meantime is there something you suggest for troubleshooting?
Already tried to remove and pair again, with no success.
Thank you for the support!

Regards,
Fulvio

Comments

  • aolaol
    edited May 13
    @FulvioBRZ I really doubt there's anything wrong with RaceChrono in regards of this... The RPM is a standard OBD-II PID and it works exactly like throttle position etc., and I'm actively using this feature myself. :)

    Please confirm that you have it set in RaceChrono > Settings > (active) Vehicle profile > Fast channels. It may have been dropped from there by mistake?

    Bluetooth pairing does not affect this. I think it's issue between your vehicle and the OBDLink LX, if everything has been correctly configured on RaceChrono side.
  • If you think that everything is configured properly, and the "Engine RPM" channel is included in the Fast channels, you could send me a test session for troubleshooting the issue:

    1) Please turn on "RaceChrono > Settings > Expert settings > Save device output".

    2) Then record a session while connected to your OBD-II reader. It is connected if the "Connecting to..." goes away and does not appear again. Short session with GPS lock, and the OBD-II reader connected is ok. No need to be at a race track, just a casual drive around is fine.

    3) Please share that session with me (using the share button, that generates a .rcz file). Please email to tracks(at)racechrono.com
  • @aol thank you for sharing troubleshooting info.

    After a weekend of trial and error I finally came up with something. I found out I had another OBD monitoring app running in the background. A soon as I stopped it and opened up RaceChrono again, the latter started receiving data from OBD including RPM.

    My next (pretty obvious) question now would be: is that right that OBDLink LX can send data to only one application at a time? I mean is it an acknowledged limitation or an issue with my setup? I know this question goes off-topic from pure RaceChrono concern, but if someone can share his opinion it would be greatly appreciated.

    If this forum is not the place to discuss of my issue, I am happy to close the topic and consider the question with RaceChrono as solved.


    Thank you very much.

  • @FulvioBRZ Ok that explains it. RaceChrono interacts with the OBDLink LX and that interacts with your ECU. It won't work properly if there's another app or device doing the same.
Sign In or Register to comment.