Galaxy S2 & Global top G33 BT GPS

edited March 2013 in RaceChrono for Android
Currently getting an error "no connection to GPS" when paired with my above mentioned bluetooth GPS.

This GPS works fine with the Symbian version of the GPS. I have used Bluetooth GPS application on the play store to connect without any issues, i am able to get a lock on satellites etc...

Has anyone experience the same problems?

Galaxy S2 ICS 4.03 and the latest version of Racechrono from GooglePlay.
Note: I did have this working previously by disabling the Pbab bluetooth service on the phone, but this work around no longer works.

Comments

  • Hi, the Galaxy S2 ICS firmware seems to have couple of Bluetooth problems.

    Not sure why it works fine with other applications, maybe they have managed to do workaround to this problem. Can you try it with few other (free) apps that support Bluetooth GPS, and report back?

    What I changed for v2.04 (from v2.03) was I created a workaround to fix the S2 ICS Bluetooth disconnection problem. It's possible that this interferes with your workaround. What I'd like to do is to fix the problem altogether, not just enable the cumbersome workaround again.
  • Thanks for your ongoing support, ill try a few more apps and report back.

    Cheers
  • had some time so I ended downloading 4 apps of which I had success with two, apps downloaded.
    Working: Bluetooth GPS Provider, Bluetooth GPS
    Not Working: GPS Mouse, GPSInfo

    Of the two that were working Bluetooth GPS Provider worked each and every time, however Bluetooth GPS had some problems with an error connection refused and took a few times to get the BT connection.

    Some screen shots for Bluetooth GPS:
    Connection Refused Error -http://users.tpg.com.au/dang8/RacheChrono/Screenshot_2012-07-06-19-44-04.png
    Working - http://users.tpg.com.au/dang8/RacheChrono/Screenshot_2012-07-06-19-44-25.png

    Screen Shot for Bluetooth GPS Provider:
    http://users.tpg.com.au/dang8/RacheChrono/Screenshot_2012-07-06-19-44-58.png
  • have updated the to the latest version of RaceChrono on GoogePlay but still dont have any luck? just wondering if there will be a potential fix for this? or if i should get a qstarz?

    PS- i have tried on a galaxy S3, HTC desire and HTC sensation with the same problem
  • aolaol
    edited September 2012
    It's unfortunate the GlobalTop receiver doesn't work even with the latest fixes :( I'm sure it will work at some point, but it is probably not too much comfort to you. If you want a new receiver, maybe search a place to buy the brilliant Garmin GLO 10 Hz GPS/GLONASS receiver. It is excellent! I bought it from here http://www.thegpsstore.com/Garmin-GLO.aspx for $99 + $39 for shipping.
  • thanks for all your help, ill keep it with my symbian device for now :)

    im thinking about getting this device, qstarz bt-q1000ex so I can use it with my motorcycle on track days, wont need a live timer on the bike but if it pairs with the phone for track days it will be great.
  • seems to work fine now with v2.11

    Note I am now rooted with the CM9.1 ICS4.04, however prior to 2.11 this was not working previously. Thanks for the updates
  • danga, good to know that I got it fixed, thanks for notifying me!
  • no thank you for your continued effort to improve what is already a fantastic product.
Sign In or Register to comment.