Racechrono not connecting to Bluetooth QStarz GPS anymore

Bit of an odd one.

Have been using this for some time, no issues, since the last time I ran it, I don`t think anything has changed on my phone, perhaps a new update, I`m not sure.

Anyway, I was at Donington the other day, turned on GPS, bluetooth on phone.

On Racechrono, it showed

Next to it were the lines

Yet going into live timing saig `No GPS Signal`.

I loaded the app `Bluetooth GPS` and it correctly located and talked to the GPS, showing the GPS had a full signal lock.

I uninstalled Racechrono, reinstalled and still the same.

Any thoughts ?


  • Hi Nigep, which GPS, which phone and which OS version? Also which RaceChrono version, I'm guessing latest if you installed from Play Store? I did change something to previous RC version related to this... If I get the information I might be able to send you a fixed version for testing.
  • GPS is the QStarz Q818EX I`ve used for a few years now.

    HTC Desire S with ICE DS v 6 ICS 4.0.4 Sense 3.6

    Racechrono 2.11 from the store.
Sign In or Register to comment.