"No connection to GPS" or "Connecting to GPS" when using Bluetooth GPS


I just want to inform that QStarz BT-Q1000X + HUAWEI U8836D device with Android 4.0.4 + RaceChrono 2.21 is not worked

Message "No connection to GPS" appears.

Only recording in RaceChrono thru BlueGps4Droid is worked. "No fix to satellites" message always showing, but recording track is worked without drops.


  • aolaol
    edited August 2013
    This problem exists on Android 4.x on following devices:

    - Huawei U8836D
    - Lenovo A830
    - Acer Z120
    - Medion E4002
    - I have reason to believe that same problem exists in all devices using same bluetooth chipset. Please reply to the thread if your device is not listed and it is affected by this.

    Here's how to workaround the problem:

    1) Update to latest version of RaceChrono from Play Store
    2) Make sure no other app is running that uses the external GPS!
    3) If you still do not get connection, enable "RaceChrono > Settings > Expert settings > Bluetooth fix"
  • Added Medion phone to the list
  • Ok. Only with new feature "Bluetooth fix" enabled I can record NMEA packets, but with already paired (but not connected) device I have problems. Sometimes connection was not established after starting new session. And after that if I switch-off Bluetooth on the phone, then I can't to switch it on! Need reboot my phone to bring back BT functionality.
  • Same problem here with Motorola Defy with Cyanogen 4.4.4; Racechrone 3.2 and Garmin GLS
    Sporadically get the message "No connection to GPS"

    Bluetooth fix not tested (should have read this thread before - sorry)

Sign In or Register to comment.