Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Motorolas G and Dual XGPS160 problems

I have the firstgen Motorola G running Android Kitkat 4.4.4 and using a Dual XGPS160 with 1.3.5 firmware and the SkyPro app recommended by Dual as tyhis was the only way I could get the Dual's Bluetooth indicator to light. My phone would pair with the Dual but it wouldn't send data or connect without SkyPro. My first trackday with this was a complete washout. My paths were only on the track when they were crossing it and were usually a couple hundred feet off and at an angle to the track. Speeds in high speed areas were much lower than actual as well. I read here that it is recommended not to run a helper app like SkyPro. What should I do to get a decent result?

Comments

  • Oh - the track was Miller in Utah. Satellites varied from 5-11, steady 10Hz rate.
  • aolaol
    edited July 2015
    Hi, with RaceChrono do not use any 3rd party apps to connect to the GPS. Configure "RaceChrono > Settings > Device #1 > Type > Bluetooth GPS" and select the correct device from below. Then it will connect directly to the GPS. This is probably the step you were missing when connecting to the GPS.

    Not sure if that will help accuracy, but make sure your GPS is installed so that it can "see" to the sky with minimal obstructions.
  • That is what I initially tried to do. The only way I vould get the XGPS160 to show up as a device was by startimg Skypro first. What exactly do you do. Starting from prior to pairing.
  • aolaol
    edited July 2015
    I have 1.2.0 firmware on my XGPS160, but I do not think it matters.

    It is likely that the Bluetooth device name for your GPS was not fetched correctly, and RaceChrono showed you only the MAC address of the device, something like "00:11:22:33:44:55". It is confusing, I know. I just run few tests and experienced this. If all you can see is the MAC address and not the device you were expecting, you might as well try that.

    Make sure you configure "RaceChrono > Settings > Device #1" so that the device type is Bluetooth GPS and the Bluetooth device is your device (be it MAC address or the Bluetooth name). Then start new session and press the red (or hopefully green) button at bottom left corner of the timer screen. It will show the status of the devices. That should say "Bluetooth GPS" and your device name. Hopefully it changes from "Connecting..." state to "Connected" state.

    If there's no Bluetooth name at first, it will be resolved to the operating system after the first connection by RaceChrono. Although RC won't show the name before re-selecting it from the bluetooth list.
  • Will retry.
  • Ok I did a walk with it. Booted ip Skypro to delete XGPS160's log of prior sessions so it was not full. Closed Slypro. Opened Racechronp amd confirmed XGPS was device #1. Hit start, new track and set ofg. Got back at 9 min. Stopped recording in Racechrono and reviewed session. It worked! Other than my path wandered 2-10m from my true on the sidewalk path. Satellites 15-17. Always 10hz. Speed 3mph avg. So I will try again to see if this continues to work. Surprised that path accuracy was so bad. I held the gps in my hand, face up for the duration.
  • Sorry about spelling. Phone.
  • OK, good it works. 2-10m accuracy in GPS is generally not too bad, but I think the XGPS160 should do a bit better. I'd say 2-5m accuracy could be expected. Notice buildings and trees will confuse it a bit.
Sign In or Register to comment.