DIY GPS data format?

I'm starting a project to build in a GPS onto my bike so I don't have to mess with a GLO anyone. What GPS message format does RaceChrono expect? I saw there is a great thread with RC3 format information, but I haven't seen equivalent for GPS




    RaceChrono needs either combination of $GPGGA/$GPRMC or $GPRMC/$GPZDA/$GPVTG
  • Perfect, thank you!
  • Most of the GPS chips will output in NMEA format, so it might be that all you need to do is to re-route the data over Wi-Fi or Bluetooth.
  • That's the plan...

    I've managed to get some GPS data to pass through to serial. I'm debugging a bad string though. And I've managed to get a bluetooth connection... so debugging then put it all together! It sounds so easy
  • Just to verify, RaceChrono only logs RC3 acceleration data, correct? It isn't used for any GPS augmentation or correction?
  • Well, this project got put on hold for awhile, but I'm back at it again.

    I've got NMEA sentences passing through Bluetooth to my phone and RC will connect and show a data rate, but says "No Satellite fix - Waiting for data...". I'm able to read the following via a terminal app

    RMC+GGA only

    Also tried a full dataset. But still "No Satellite fix - Waiting for data..."

    Connecting via USB to my computer I see the same messages and am able to get a positional lock and info (although no magnetic info from RMC)

    What am I missing to get my setup working with RaceChrono? I've tried pairing/unpairing; "Bluetooth fix" on and off.

  • Can you send me uncensored NMEA feed (like 5 minutes worth) to tracks(at) ? I will take a look why it's not working. Please compress it to .zip so linefeeds etc will remain intact when I download it.
  • email sent! Thank you for the help
  • Just checking to see if you had been able to look at the files I sent
  • Hi, you have broken line feeds \r\r\n. RaceChrono does not recognise this as it needs \n or \r\n. I've fixed it to allow \r\r\n in future, but won't release in a while, and I guess it's worth fixing anyways.
  • That fixed it, thank you!!!

    I changed readStringUntil('\r') to readStringUntil('\n')
    and serial.println to serial.print

    The extra \r is gone and app is connecting/receiving perfectly!
  • I have exact same problem with DIY GPS but I don't understand this fix:

    """"I changed readStringUntil('\r') to readStringUntil('\n')
    and serial.println to serial.print"""

    Please tell me step by step, how to make this change. Is it on RaceChrono App side OR GPS module side?
  • Hi...I'm in the process of designing and building a custom data collector. It has the ability to send data over a Bluetooth connection (serial port) to a phone. Does LapTimer have any facility for accepting data from such a device? It will be sending standard GPS NMEA sentences but can also send data from a bunch of other sensors. For example values read from the CAN bus, 3 axis acceleration, 3 axis gyroscope, temperature, analog inputs, digital inputs, etc.
  • Here's the latest version of DIY summary
Sign In or Register to comment.