Configuring Garmin GLO 2 with Android phone (was: Problem in receiving GPS coordinates)

edited May 2020 in RaceChrono for Android
I'm new in this forum and I found a few similar topics here but I don't think any of them addressed the same problem as the one I have. So my GPS is Garmin GLO 2 and my phone is Huawei Smart P 2019 with Android 10, EMUI 10.0.0. RaceChrono v6.3.5.

I can successfully BT-pair GLO 2 with my phone. Garmin's instructions here worked fine with my previous phone, Honor 8, but in this phone there is no setting named "Allow mock locations". There is a similar setting in hidden Developer Options, but if I enable that, it makes the Bluetooth GPS app crash when connected with the GPS device. However, Bluetooth GPS app can show GPS coordinates (which I assume it must get from the Garmin device because the phone's own Location feature is turned off) even when "Enable Mock GPS Provider" is not checked, so I assume the problem is in transferring those coordinates to RaceChrono. So RaceChrono says the current location is unknown.

I should also mention that even though I have the latest version of Bluetooth GPS app installed, it still says that it was designed for an older version of Android and it might not work correctly with my phone. I do not have the contact information of the developers of that app so that I could ask them. I also read in this forum that Huawei has some issues in their firmware, but to be honest I don't really think they will care to fix them so if those issues are causing also this problem, I hope there is a way for another component to implement a workaround.

Can anyone help with this? I'll be happy to give more information if requested.


  • Hi, the Garmin instructions are incorrect for RaceChrono. Just ignore them.

    1) Do NOT install the "Bluetooth GPS" app. If you did, uninstall it.

    2) Add the Garmin GLO receiver to RaceChrono from "RaceChrono > Settings > + Add GPS receiver".

    3) Now you're good to go, just start the session.
  • edited May 2020
    Thank you for the quick reply but unfortunately it did not solve the problem. I uninstalled "Bluetooth GPS" app and tried to make RaceChrono connect directly with GLO 2 but it does not: the blue led on the receiver blinks, which means it's not connected to a phone, and also RaceChrono still says the current location is unknown. I tried both pairing the device first in the phone's Bluetooth settings, and not pairing it but letting RaceChrono 'Search for devices in range', but in either way it does not seem to connect.
  • Moth methods should work, paired in the OS or not paired. Try updating the GLO 2 firmware, the early firmware v2.10 was broken. The new devices should ship with later firmware, but maybe you got one of the older ones.
  • Garmin WebUpdater says my device already has the latest software version. It does not say the version number though.
  • Is there a way to debug this, get information on what is going on?
  • edited May 2020

    One more thing you could do is hard reset the GLO 2 device. Instead of turning it on with short press of the power button, try long press of 20 seconds.

    Also make sure you select the correct device when adding it in RaceChrono settings. The device name should be "Garmin GLO 2 #xxxxx". The device's blue led should be blinking after it is selected. Once you press 'START' on the RaceChrono's main screen, the device should be connected shortly after, turning the blue led to solid on.
  • Thank you, now the problem is solved. I did not need to hard reset GLO 2. The problem was that I never hit the 'START' button on RaceChrono, instead I checked the connectivity by hitting Tracks --> Nearby. I have always used it so that I first select a track and then I hit Start. With your instructions I now realized that it only connects Bluetooth when the Start button is hit. I wonder if it should support showing the nearby tracks list also with an external GPS? Anyway, thanks a lot for the help!
  • edited May 2020
    Ok, great to hear it got solved! The track list uses internal GPS when there's no ongoing recording. It doesn't really need great accuracy.
Sign In or Register to comment.