DIY Antenna GPS 10Hz ( chips: GPS NEOM8-N + Bluetooth JDY-30)

i tried to build this 10hz GPS antenna. I tried to pair with Racechrono, but it doesn't work.
with the Android app Serial Bluetooth i tried to connect on the DIYAntenna directly, this is the output:

09:00:40.479 $GNRMC,,V,,,,,,,,,,N*4D
09:00:40.479 $GNVTG,,,,,,,,,N*2E
09:00:40.479 $GNGGA,,,,,,0,00,99.99,,,,,,*56
09:00:40.479 $GNGSA,A,1,,,,,,,,,,,,,99.99,99.99,99.99*2E
09:00:40.586 $GNGSA,A,1,,,,,,,,,,,,,99.99,99.99,99.99*2E
09:00:40.586 $GPGSV,1,1,00*79
09:00:40.586 $GLGSV,1,1,00*65
09:00:40.610 $GNGLL,,,,,,V,N*7A
09:00:41.759 $GNRMC,,V,,,,,,,,,,N*4D
09:00:41.759 $GNVTG,,,,,,,,,N*2E
09:00:41.759 $GNGGA,,,,,,0,00,99.99,,,,,,*56
09:00:41.759 $GNGSA,A,1,,,,,,,,,,,,,99.99,99.99,99.99*2E
09:00:41.811 $GNGSA,A,1,,,,,,,,,,,,,99.99,99.99,99.99*2E
09:00:41.811 $GPGSV,1,1,00*79
09:00:41.811 $GLGSV,1,1,00*65
09:00:41.835 $GNGLL,,,,,,V,N*7A
09:00:42.494 $GNRMC,,V,,,,,,,,,,N*4D
09:00:42.494 $GNVTG,,,,,,,,,N*2E
09:00:42.494 $GNGGA,,,,,,0,00,99.99,,,,,,*56
09:00:42.494 $GNGSA,A,1,,,,,,,,,,,,,99.99,99.99,99.99*2E
09:00:42.584 $GNGSA,A,1,,,,,,,,,,,,,99.99,99.99,99.99*2E
09:00:42.584 $GPGSV,1,1,00*79
09:00:42.584 $GLGSV,1,1,00*65
09:00:42.606 $GNGLL,,,,,,V,N*7A

Have you any suggestions?

Thanks a lot

Luca from Italy


  • Configure it to output $GPRMC and $GPGGA. The rest are really not needed so you can disable them.
  • ok. perfect! i'll try to do it.
    thank you.
  • i tried to disable GLONASS and set UBX+NMEA+RMC in the output string. this is the output now:

    16:40:52.547 $GPGSA,A,1,,,,,,,,,,,,,99.99,99.99,99.99*30
    16:40:52.547 $GPRMC,,V,,,,,,,,,,N*53
    16:40:52.547 $GPVTG,,,,,,,,,N*30
    16:40:52.637 $GPGGA,,,,,,0,00,99.99,,,,,,*48
    16:40:52.637 $GPGSA,A,1,,,,,,,,,,,,,99.99,99.99,99.99*30
    16:40:52.637 $GPGSV,1,1,00*79

    Do you think could be right?

  • i need your help. :-(

    before making the changes you suggested, I performed a factory reset through the U-CENTER interface.
    Now it never locks on any satellite.

    Thank you
  • Hi, no idea unfortunately. I do have M8 chip here that I'm planning to try on my DIY stuff, maybe can answer this later...
  • I encountered similar behaviour, but it did start working again after a few minutes.
    In U-Center I did a CFG - "Revert to default configuration". Then it takes many minutes to get a lock to satellites again, even if you send the Almanac through 'A-GPS'.

    While my USB-GPS receivers function flawlessly (but not with RaceChrono - I should try to connect them to my phone!), my GPS module connected through a USB-serial connector behaves erratically in U-Center. A-GPS data is not always kept and the newer constellations (Beidou, Galileo) are not reported - but I think they are received.

    Also if you remove the GxGSV(?) records, U-Center does not report the satellites. So it may look like it is not receiving, but it does use them to calculate position.
  • What is the list of supported NMEA messages and talker id's ?
    * RMC and GGA are mentioned above: these 2 are pretty standard for a complete positioning decoding (HLT uses these)
    * GSA and GSV are used when available to display the constellation of satellites, perhaps optional? If used, can they be sent with a lower frequency (e.g. every 1, 2, 5 secs)?
    * I see that sending GPS, Glonass, and Galileo works - is anything but GP ignored? Should other talker be changed into GP talker id?
    * is GBS used?

    Thank you!
  • - Only GGA+RMC or RMC+VTG+ZDA combinations are used
    - GSA+GSV are optional
    - Sentences need to start with $GP
    - GBS sentence is not used (as stated above)
  • Hi,

    I found the solution.

    The problem was the internal GPS antenna.

    I tried to connect a simple electricwire and now it works.

  • hi,
    this is my output on RaceChrono
    it seems to be right, but I notice that the GPS update is not stable (14Hz is the GPS setting) it alternates between 6 and 13hz.
    Is it normal? Could be the of the serial communication? Now it is set 9600


  • Most definitely 9600 baud rate is not enough for 14 Hz NMEA. Try 19200 or 38400.
  • Good morning to all

    It also does the same thing to me, I configured the GPS to 10Hz but on race chrono it oscillates between 7 and 10hz.

    The bluetooth module baudrate is set to 38400 as well as the gps serial output.

    Doing some tests it seems that this happens only by communicating with the smarphone, I also tried connecting it to the computer via bluetooth and in that case the frequency is stable at 10hz.

    How did you guys solve the problem?

  • Did you managed to get it stable when connected to phone?
  • For the moment yes, I have changed the GPS settings so that it only provides me with GGA and RMC type messages.
    It is currently stable at 10HZ.
    Another problem I have encountered is the maximum number of satellites I can acquire is 12 (probbilmente this is a limitation of the GPS module used at 10Hz).
Sign In or Register to comment.