Export failed after editing synchronization

At a trackday I recorded four sessions each of about 40 minutes with RC for IOS, video source was a GoPro 4.
After downloading the videos I edited the sync of three sessions, which were off about 200ms. Now I can't export the three edited sessions (MP4+overlay). I always get a “Failed: Video/audio codec” error. Viewing the videos + overlay in RC works.
The fourth session, for which I didn't touch the synchronization, exported without problems. Synchronization is off by 200ms as expeced.
How can I get my videos + manually synchronized overlay exported. I didn't find a solution in the forum or in the FAQ.
Or is it at least possible to restore the original sync values in RC?

iPhone SE 2020, 256GB, IOS 3.7

Video Source:
GoPro 4, Channel 2, 1920x1080, 60 Hz


  • edited September 2020
    RaceChrono has an unfixed bug that causes the Video/audio failure on iOS. Basically it happens when there is three or more linked video files that belong to the export, and a gap between each of the files. You can workaround the problem by exporting only single laps (so that there's only one or two linked video files included to the export).

    I'm investigating the issue in coming days, hopefully I can fix it.
  • Thank you for caring. I've are 4-6 files for each session (11.49 min = 4GB each file), total size is 11-15 GB for each session.
  • edited September 2020
    I did find a problem and it is fixed in v7.0.8. It is most likely the same bug causing your issue.
  • I just tried the export with v7.0.8 but the result is the same, I can't export the entire session. Your hint to export only laps already worked with the previous version.

    Maybe it helps to find the bug, I could export all of my laps by selecting "laps" instead of the entire session. But I had to split two sessions for exporting - e.g. export-1 lap 1-6 and export-2 lap 7-12. These sessions used 5 and 6 videos. At two sessions I could export all laps without splitting, they only used 4 videos.
    All RC seesions were started in the paddock, which is a bit off track. The track was Hockenheim GP. I used my iPhone for GPS, as expected the accuracy and speed was not the best. Despite the overall result was ok, the next buy will be an external GPS...
  • @db01 OK, it was still worth a shot, I fixed something that I was able reliably to reproduce.

    Your bug must be something else. If you want, you could share me the session (as .rcz file) and _all_ of the raw video files that are linked. Obviously you'd need to upload them to cloud, and share the links to me. If you want me to look at it, please send the links to the file to tracks(at)racechrono.com
  • I've sent you a mail with the links, thanks.
  • @db01 Turns out my previous fix only partially fixed the problem. This will be fixed (again) in v7.0.9
  • RC v7.0.9 works fine, I could export the “Whole Session” of all four recorded sessions. Thank you very much for your superb support.
Sign In or Register to comment.