OBDLink MX+ Bluetooth on iOS not connecting

So, all of a sudden, RaceChrono doesn't want to connect to OBDLink MX+ Bluetooth. The adapter is connected in the iOS, and other OBDII apps can read the car's data, but nothing in RaceChrono. There was a Firmware update done on the adapter done recently, but it worked in Racechrono afterwards. Just hasn't worked since yesterday. Any suggestions?


  • I should add that I did remove and reconnect the adapter in the iOS, and also in Racechrono, and I also restarted the phone.
  • It should work after the following resets.

    1) Unpair OBDLink MX+ from your phone's Bluetooth settings

    2) Pair your OBDLink MX+ again in the Bluetooth settings. You need to press the button on the OBDLink to make it pair again

    3) Remove OBDLink MX+ in RaceChrono settings

    4) Add the OBDLink MX+ again in RaceChrono settings, using the "Add OBD-II reader" button

    Now it should at least connect again.
  • OK, I thought I did that already, but I'll try again.
  • edited June 2021
    Also make sure it says "Connected" for the MX+ in the iOS Bluetooth settings!
Sign In or Register to comment.