OBDLink LX not connecting

Moto G Fast

Android 11

GPS access allowed all the time

Bluetooth enhanced connection switched on in Expert setting

RaceChrono Pro trial version

The phone is paired to the LX. I added some CANBUS PIDs and when I test the connection via vehicle profile, RaceChrono connects almost instantly is able to read the CANBUS and provide live data.

However, when I start recording a session from the main screen, the app never connects to the LX as evidenced by the red “connecting to LX” banner at the bottom never disappearing.

I had the same issue with an MX+ originally which is why I was trying this with an LX, but I still see the same issue even after forgetting it and pairing again.

Do you have any suggestions to try?


  • edited April 2022
    Please try the following:

    1) Remove OBDLink LX pairing from the phone's bluetooth settings

    2) Remove the OBDLink LX from RaceChrono settings and add it again

    3) Press the small button on the OBDLink LX, before connecting for the first time again. The indicator led needs to be flashing quickly (pairing mode).
  • @aol - Thank you for the suggestion. I removed the LX from both the phone BT settings and RaceChrono settings. I then re-paired the LX with the phone and and then added the LX in the RC OBD-II readers section.

    When I tried recording a session (just in the garage), the red banner at the bottom disappeared and it recorded three OBD parameters I selected. So far, so good.

    I then added the same LX in the "Other Devices" section to record data (brake pressure and gear) off the CAN-Bus and tried recording another session and RC went back to not connecting with the LX.

    I went through this whole process (removing LX and re-pairing) twice and was able to repeat this sequence/ issue.

    What is interesting is that when I go into vehicle profile, I can test the OBD connection and see OBD data, switch off this test connection, test the CAN-Bus connection and see data from the PIDs I inputed. When I go back to recording a session, RC does not connect to the LX. I see "Connecting... (waiting)" for both OBD and CAN for the most part. Occasionally, I'll see Connected for the OBD portion but then it will revert to "Connecting... (waiting)".

    Any thoughts on this?
  • @Alchemic did you configure the same adapter as both OBD-II reader as well as CAN-Bus reader? That doesn't work unfortunately, it's only either one.
  • edited April 2022

    Oh, ok. Yes, I did and obviously that’s the issue here. So, I can either read CAN-bus data or OBD, not both. Got it.

  • edited April 2022
    @Alchemic Yep, it's a limitation of ELM 327 protocol unfortunately. The hardware and the bus could easily support it, if the command set was a bit better.
  • Thanks, @aol. Just purchased the pro version because of your exemplary support.
  • edited April 2022
    A couple additional quesitons, if I may. Looking at the live data from the OBDII stream, I can see the PID for say engine RPM.
    1. Will the PID from OBD be the same on the CAN-bus side?
    2. If yes, is there a way to "copy-paste" the PID and equations from OBD to CAN-bus?

    The reason I want to use the CAN-bus data instead of OBD is that front brake pressure is available on CAN-bus, but not OBD. And I have the PID for it.
  • No, the OBD-II PIDs and CAN-Bus PIDs are a separate concept.
Sign In or Register to comment.