No CAN data on OBDLink MX+

Hi, Great forum and support discussions! I couldn't find something to help me so decided to ask. I don't see more than 0.0 data rate coming across the test CAN connection even though it says it's connected. Any ideas where I went wrong?

I have a 2017 BMW F87 attempting to connect with the following:
Samsung S8
Android version 9
Race Chrono Pro Trial
Obdlink MX+ firmwares tried so far

Race Chrono app settings:
No OBDII device,
External Can bus source as Obdlink MX+,
Expert>Experimental device enabled
SafariEdition PIDs from,

Test connection shows connected, but 0.0-0.1

Thank you in advance!


  • edited April 2023
    @Xeph1 Here's the two most likely reasons

    1) There's no CAN-Bus messages available where the reader is plugged in. Modern cars have multiple buses, and many cars do not expose the internal CAN-Bus packets on the diagnostic bus (the one with the OBD-II socket), but only the messages related to the OBD-II.

    2) The PID numbers are not properly configured, so RaceChrono is not seeing them, after it configures filtering.

    All the messages in the bus should be visible with "AT MA" command send to the OBDLink reader. Unfortunately there's no feature in RaceChrono for this, but a terminal connecton to the reader is need for entering that command.
  • @aol_of_RaceChrono Thank you for the prompt reply and suggestions.

    An update on my troubleshooting progress:
    Moving through the matrix of options, I found that:
    - switching the Bluetooth update rate fix to "enabled" triggered data flow on the test CAN connection. This held true moving back to the 5.8.1 OBD firmware also.
    - Forcing the OBDLink MX to Manual pairing via the button, allowed me to create the data flow on demand rather than at random, as it was doing.

    Current problem now is, that despite there being CAN data coming in the connection, it does not resolve into raw data in the logging. The MX device is listed as connected with 187kbit/s data coming in, but the message from CAN-bus reader is Waiting for data ...

    How does this new info change your hypothesis on the source of the issue? Do any of the OBDII setting influence which PIDs are in range for the CAN bus functionality? I have not tried settings in there at all.

    I have used SENA BTerm in the past, will this be sufficient to execute the terminal commands? Any other details on this process? I gather it will just allow me to verify if, and what, messages are coming across.

    1) I was also wondering about this aspect. Digging into it left me with the impression that the F87 platform has been configured by other users of Race Chrono to access the CAN messages via the OBD connection. Maybe not conclusive.

    2) Not sure if you mean the fields of the formulas, etc.? I got no errors on their entry and they are supposed to be verified PIDs for the car. But the live data does not change on any...

    I really appreciate your help on this, I enabled the debug and raw data options also if any data or files will help.

    Thank you,
  • edited May 2023
    @Xeph1 I'm afraid random stabs at the expert settings etc. will not solve this. The expert settings usually solve a specific bug or a problem, but they may also prevent some other things from working. The "update rate fix" may break this feature.

    Usually this feature works bulletproof. There's no tricks to make this feature work, you just need to configure correct CAN-Bus channels with correct PIDs, connect the reader correctly to the bus with the corresponding messages, and configure the reader as "CAN-Bus" reader in RaceChrono settings.

    So before continuing, please confirm, with other tools, that your bus really have the messages with the PIDs you've configured. Otherwise you're wasting your time I'm afraid.
Sign In or Register to comment.