GoPro5 vs GLO

There is a problem in simultaineous usage of GoPro5 and Garmin GLO.

Connection to both devices is ok. And starting session too. But when I go to Camera tab and starting video recording, "connecting to gps" appears in 1-2 sec. And no gps data is recording.

First time I've found this problem about a year ago on Xiaomi Redmi Note 3 Pro (Snapdragon 650). I've thought, that problem may be in some funny realization of wi-fi/bt in this smart.

Now I have the same problem on Mi Note 3 (Snapdragon 660).

"Internet" says, that some people got problems with connection speed and stability when wi-fi and bt are both on at SGS8.

BT-fix on/off in app, gps on/off at GoPro - no difference.

GoPro5 and 6 using wi-fi and bt in connection to smart. May be the problem is here.

I ran out of ideas....


  • Please join beta group (instructions in FAQ), there is new version with 100% new GoPro support. You can either use the GoPro 5/6 support to connect using Bluetooth+Wi-Fi or GoPro 4 support (works with 5 and 6 too) to connect with Wi-Fi only.
  • aolaol
    edited May 2018
    Just rode 50km with Garmin GLO and GoPro 5 yesterday without problems, using the new beta.
  • In beta version can't connect to GP in WiFi+BT mode. App trying to find camera couple of minutes without the result. But in WiFi-only GP4 mode all works fine.
    Problem solved. Thanks a lot , Antti! :-)
  • Yes, the WiFi+BT mode is a bit problematic on Android. It's hard to get it working. I'll improve to user interface, so that it's more obvious to configure GoPro 5/6 to Wi-Fi only connection.
  • Gp4-mode works fine for now. And this is great!

    Possibility to download video from camera by Wi-Fi is MEGA! :-)
    This is much simplier and faster way then sticky-sweaty-greasy dealing with otg at rally service park.
  • Is there any option not to turn-off the camera after finishing the session?
  • Currently no.
Sign In or Register to comment.