Missing data at 5Hz in S60

First of all, I must say a big thanks for an excellent software.
I just recently found out about it and started to test it with my Holux M1200 GPS (set at 5hz) but I have the following problem. I searched the forum but couldn't find anything similar.

When I tried Racechrono with my Nokia 6110, it seemed to work fine but on closer inspection, it skips a lot of time points.

Here is a sample of an exported file
008 142030.40 +02280.42500 -01427.04720 020.82 300.59 +0173.71
008 142031.40 +02280.42670 -01427.04410 016.82 297.16 +0173.00
008 142032.20 +02280.42760 -01427.04190 013.91 285.80 +0172.50
008 142032.40 +02280.42780 -01427.04150 013.08 281.16 +0172.50
008 142033.20 +02280.42890 -01427.03930 011.93 275.42 +0174.50
007 142034.20 +02280.42970 -01427.03580 011.91 262.42 +0177.21
008 142035.00 +02280.42950 -01427.03390 011.35 238.88 +0177.89
008 142036.00 +02280.42810 -01427.03210 015.30 003.00 +0178.39
008 142036.80 +02280.42640 -01427.03000 018.93 221.57 +0179.01
008 142038.60 +02280.42140 -01427.02430 025.02 221.38 +0179.10
008 142040.40 +02280.41490 -01427.01780 032.24 217.67 +0178.71
008 142040.60 +02280.41420 -01427.01700 032.85 215.98 +0178.71

I played around with baud rate of the gps but no change.
Then I tested the same GPS with a Windows Mobile 6 device and there is no problem at all.
008 160811.00 +2273.98820 -1441.64900 13.24 289.80 +69.20
008 160811.20 +2273.98830 -1441.64850 13.06 287.43 +69.20
008 160811.40 +2273.98840 -1441.64800 13.69 286.34 +69.40
008 160811.60 +2273.98850 -1441.64740 13.70 281.98 +69.29
008 160811.80 +2273.98860 -1441.64680 14.24 280.64 +69.11
008 160812.00 +2273.98880 -1441.64610 14.83 278.83 +69.11

Any ideas what is going wrong with the S60 version? Is 6110 too slow to log at 5Hz?
Thanks

Comments

  • aolaol
    edited April 2009
    This happens when there is not enough bandwidth to output the sentences. The receiver just skips some. Have you tried to set the baud rate higher from RaceChrono settings? Or possibly make GSV and GSA sentences more infrequent (once per second, not 5 hz).
  • Didn't know I could selectively change the rate of different sentences. I changed them and it seems to work nicely.
    Thanks
  • Very good you got it fixed!
Sign In or Register to comment.