Overlaid Video flips horizontally upon Export

Hi,
I am new to the software and this forum and this is my first post for help.

I am using the export function with overlaid data to watch the video on a bigger screen but it all comes out flipped horizontally .
the only option where I saw you could flip the video horisontally is amongst the PIP options but I am not using this feature at all and it is disabled altogether.
Still the video comes out flipped when you export.
When I link the video to the data and in the analizing screen I can play it and it is perfectly fine. Only when you export it comes out flipped. Video is from a gopro camera.

Any help is much appreciated.

Comments

  • @Neychev flipped horizontally? Sounds really weird... So I have to check if you use correct terminology? Do you really mean flipped horizontally (this is what selfie cameras do), or maybe you mean upside down (rotated 180 degrees)?

    There is option in "Videos screen" on each of the linked videos, to rotate 180 degrees. This will rotate the video 180 degrees in both Analysis and Export.

    Let me know if that is not what you want, and let's then continue with screenshots etc to clarify the problem.
  • edited May 2019
    @aol Thanks for your input.
    By flipped horzonatlly I mean left is right and right is left, not upside down.
    How do I send you screenshots? I do not seem to be able to attach anything to posts here?
    I am using bluestacks android emulator on my PC to do the export so I have more power than on the phone. Could that be relevant to the issue?
  • @Neychev I'd say it's Bluestacks issue as I've never heard of such problem before. The phones are actually usually faster to encode due to powerful hardware acceleration required by cameras. You could use ffmpeg to flip afterwards, if you want to continue to use Bluestscks.
  • @aol Hey, I found out shortly after by experimentation what the problem was with the flipping video. Wanted to share in case someone else has the same issue.
    So the Hardware acceleration options is normally clicked/active but if you use an android emulator on PC like me it flips the video horisontally upon export. If you deactivate the hardware acceleration option it comes out just fine. This works if you use BlueStacks like me on PC with Windows 10 x64.
    Have a great day all.
  • @Neychev can you please tell me how to deactivate the hardware acceleration option? I'm facing the same issue with the inShot app. Thanks!
  • I had the same problem when running RaceChrono Pro on a Windows 10 laptop using Bluestacks 5. The issue was resolved by deactivating hardware acceleration. You do this from the Export Session window. The option 'Use hardware acceleration' is revealed when you choose the 'Show more ...' option. Make sure this is unticked and the exported video will not be flipped.
    An oddity. The RaceChrono Pro version running under Bluestacks is 7.4.1 shows the 'Use Hadware Acceleration' option. But the same version running on my Samsung Galaxy S9 phone, which I used to record the lap data, does not show this option. It shows another option 'Picture-in-picture video channel' which is disabled by default with no other setting option available. This Picture-in-picture option is not shown in the version running under Bluestacks. Curious.
    However I must say that running RaceChrono Pro via Bluestacks 5 on a Windows 10 laptop is worth doing as both the video and the data trace are displayed much larger than on my phone and so are much more easy to see.
  • @sion The software codec is only available on Android 9 and older. Android 10 and later only have the hardware codec, so the option is not available.
Sign In or Register to comment.