Could not reach the GPS receiver

This issue has come up a few times but it seems it is not resolved yet. I have the same problem:

I want to connect to my AD850 bluetooth GPS using a Nokia E65 and it shows up in the search list. However, when I try to connect to the device, it displays the error:
"Could not reach the GPS receiver. Try same receiver again?"

This have been the suggestions I gathered from the forum:

1) Recharge your GPS battery
2) Re-boot your phone
3) Answer "No" to "Try same device again?", and search again for the GPS.
4) Are you already connected to the GPS from the phone? Try to unpair the GPS from the Bluetooth settings, and then connect with RaceChrono.

I tried them all and none of them work. Other applications connect to the GPS just fine, except RaceChrono. So I really thing it is a RaceChrono software (API ?) related problem. Any chance fixing it?


  • Might be RaceChrono problem, I don't know. Try to connect to the GPS from the Bluetooth settings of your phone (basically just pair it). Then go to phone's Location settings, and only select Bluetooth GPS from there. Now your phone Operating System is using your GPS. Then select "Internal GPS" from RaceChrono's GPS settings (actually using which ever is selected in the OS).
  • I tried that and it doesn't work either.

    The phone will pair the GPS, and the "Bluetooth GPS" is enabled in the position settings of the phone. "Network Based" is disabled. Nokia's own application "Navigator" can't even connect to my GPS but then again that APP doesn't even include an option which lets you choose which bluetooth device you want to use. The blue LED on the GPS doesn't flash so as far as the phone is concerned, there is not GPS connection. And if there is no GPS connection, the "Internal GPS API" you are using can't work either.

    If TomTom and Garmin can access my gps, RaceChrono must be able to access it too. Maybe those companies are using some super secret Uber cool API to connect to my GPS? I wish we could have our hands on that.
  • edited July 2010
    Probably the GPS is somehow non-standard that Nokia Maps neither RaceChrono works with it... If you get it working with Nokia Maps, then it will work with RaceChrono too (internal GPS setting).

    You don't choose the GPS device for the Nokia Maps, it will use automatically the GPS device that is paired in the Bluetooth settings. RaceChrono does the same in "internal GPS" setting.
  • Ah I got it to work now.

    I updated the phone's firmware (using the Nokia Software Updater and a USB phone cable) and that changed the "Navigator" program as well. This time Navigator did ask me which bluetooth device to use. I had to leave the Navigator program running in the background with an active bluetooth connection. Then I used the internal GPS feature of RaceChrono and it worked.

    So it is a phone firmware issue. Problem solved.
Sign In or Register to comment.