RaceChrono v1.30 known issues

General version 1.30 known issues:
    [li]OBD-II speed is exported to CSV in meters per second instead of the units displayed in the header. [li]Laterla-G values calculated from GPS data are exactly half of the real value. [fixed in next beta]


Symbian (S60) version 1.30 known issues:
    [li]Phone crash when lights go out in Samsung SGH-i450 and L870. Anybody else experiencing this? Can anyone loan me such phone so I can fix this? [li]Nokia E71 21.x firmware crash when switching to Live Timer mode in Data logging sessions. [fixed in next beta] [li]Nokia E62 backlight on not kept light up. Please turn backlight "Always off" from RC settings and use "spoton" software to keep them on. [li]Nokia E82 backlight on not kept light up, anyone else experiencing this? [li]Can not edit decimal values properly with Nokia E61, if the localized decimal separator is comma (Finnish atleast). [fixed in next beta] [li]Cannot go up/down anymore after pressing '#' on Nokia 6110 Navigator. Anyone else experiencing from this? Workaround is to not use '#' key at all. Switch display mode from options menu instead. [li]Nokia N95 and N95 8GB have problems with QSTARZ BT-Q818X and QSTARZ BT-Q818 eXtreme receivers. Firmware update on the phone supposedly helps, please let me know if you run in to this one. Not RaceChrono issue, but common never the less.


Windows Mobile version 1.30 known issues:
    [li]IMPROTANT: If you're having problems with installation, there one common thing to go wrong. Please use "save as file" when clicking the download link, so you save the .CAB file to your disk instead opening it. Then copy the .CAB file to your device and open it there. [li]Input panel selection icon shows up after switching back to RaceChrono from an another software.[fixed in next beta] [li]Number editors accept text as well [li]WIDCOMM Bluetooth stack not supported. If you have it, please configure your GPS and RaceChrono to use a COM: port instead. [li]Loosing editor focus when coming back from another applications (WM std) [li]Low storage space notifications not implented. [fixed in next beta] [li]Lock keys option form the session menu does not work. [li]Internal GPS setting does not work with HTC P3300 WM 6.0 (but does work with WM 5.0). Any other users experiencing from this? [li]OBD-II does not work with "Internal GPS" setting. [fixed in next beta] [li]Some in-build SirfStarIII receivers seem to work but there is no lap times. Traveled route plots are in 3 second intervals.



Feel free to continue the thread with any issues you've found. Please also mention which platform are you using.
«13

Comments

  • I've noticed that the latest beta sometimes stops recording when in use with my BT-818X GPS dongle. I upgraded RaceChrono and used the new GPS dongle at the same time, so either could be the problem. Restarting RaceChrono and rebooting the GPS dongle fix the issue. I'm using a Nokia N95 8GB.
  • The "clock" under Traveled Route just stops? Then you need to pause the session before you can exit? Could probably be a Bluetooth problem. You could try to upgrade to latest firmware, sometimes it helps.
  • Hi. Can I perform multiple straight-line Performance Tests on a single session? I tried pulling the vehicle to a standstill and running it up to 100kph again, but it does not register a second "lap".
  • Yes it should be possible. Sometimes the new start is not registered, as the GPS speed does not reach zero point in certain GPS conditions. Be sure to wait ~10 seconds in standstill.
  • Deleted the discussion about stuff that has been fixed with the latest Symbian (S60) version 1.30 beta1.
  • version 1.30 for second edition???
  • aolaol
    edited July 2009
    Hi, I'm not totally convinced yet if I will make the v1.30 for 2nd edition. I will have to see how much work is there to port the changes to 2nd. I will think about it after summer. Anyhow, I will at least remove the expiration day from v1.10 before it expires.
  • Hi Andy Laurence,

    I'm facing the same issue, V1.10 sometimes stops recording, on a Nokia N95 also using the BT-818X GPS. Have you had any success solving this?

    As I recall, V1.10 worked just fine with the N95 internal GPS (1Hz), so perhaps it is something about the 818X.
  • Thanks for the report! It's probably worth updating the firmware on the N95, but it might just be there is problems with some BT-Q818X. I never ever seen this on my tests so I'm fairly certain it's the either end of the hardware.
  • Thanks aol. Update on BT-Q818X with V1.10 stops recording: This issue only occurs with the 5 Hz setting and not the 1 Hz setting on the BT-818X. Not sure why. Will try the firmware update on the N95.
  • Ok, thanks for the update!
  • edited July 2009
    I just installed RaceChrono v1.3 on my Nokia 6110 Navigator (S60 3rd Ed FP1). There seems to be an issue with the up/down keys stopping to function. The issue is reproducible by going into a previous session and viewing lap times. The perform a series of the following actions in any order or combination:
    - Scroll up and down the lap list
    - Open a lap
    - Change the display mode
    - Open the speed-distance graph
    - Open the options menu and scroll up and down

    Eventually my up/down keys stop working and when I go back to the Previous Sessions list, I can scroll up and down again using up/down. However, while it's scrolling up and down, it now leaves a tick symbol next to the session and when I press Open (the center key) it toggles the tick next to the highlighted session and I cannot open the session. After I exit and restart RaceChrono, everything is back to normal until I start viewing sessions again.

    Is anyone else experiencing this?
  • Good find, thanks for reporting! I will contact you via e-mail to get this sorted ASAP.
  • aolaol
    edited July 2009
    Kthl, big thanks for your help investigating this issue! Unfortunately the source of this issue was not found, and the problem still exists on your phone. Please see the known issues list for work-around.
  • good idea version 1.10 vith remove the expiration day...
  • RC 1.30 is crashing my E71! :(

    I've upgraded RC from 1.10 to 1.30 yesterday, launches fine, but once I start a new session (or resume a previous session), and then click 'Switch to Live Timer' - it crashes (freezes) the whole device! The only solution is to remove battery. :( It happens every time, I've tried few times already, there's always a freeze/crash...

    Initially I thought it has sth to do with OBD-II interface, but it also crashes once I disable OBD-II totally in Settings dialog. The session I am trying to run is 'Data logging only'-type, haven't tried other types, but to be honest - that's the one I am most after.

    Unfortunately, RC 1.30 is not for me (yet). Is there any chance to download 1.10 and downgrade for time being?
  • aolaol
    edited July 2009
    Evad, oh Damn... You are first to report. These things should have been sorted out during the beta phase but unfortunately it does not always happen :( I'll contact you so let's try to get this figured out!
  • Big thanks to Evad for helping me find the issue. This will be fixed in next beta.
  • Always happy to help :)
  • hello, i've bought the HTC P3300 specially for racechrono..
    now I read above that it doesn't work with this phone on WM6 :'( is there any solution for it?

    thanks in advance
  • aolaol
    edited July 2009
    Basz: The issue with HTC P3300 was that the internal GPS could not be used. Other's have got it working with same device, so let me know if yours work or not. At least it will work just fine with external Bluetooth GPS (which I recommend anyways, a 5 Hz model).
  • I tried the internal GPS setting and it won't find sattelites, in the TT settings it says "other NMEA device" and than COM4.. ?

    otherwise I have to trie and find a new device, i want to use it with internal GPS because loose GPS device is not very easy in use when racing a motorbike in a racing overall...

    nokia 5800 is a good device for racechrono?
  • aolaol
    edited July 2009
    Well the Internal GPS is always trade-off. With the external you'll get more accurate data and lap times. Semsons.com sells the QSTARZ BT-Q818X (notice the X in the end...) for about $65. Also any other 5 Hz receiver with MTK chipset will do fine.

    I can't recommend 5800 (or almost any other phone) if you plan to use the internal GPS only... Internal GPS's are all right if you own the phone already and want to test not so seriously. With Bluetooth GPS both P3300 and 5800 are excellent! :-)
  • allright! thanks for your fast and clear answer!

    I will purchase a bluetooth GPS receiver and use the P3300 :P
  • Hi,
    I have a P3300 with WM6 Pro
    Can I help you with development?
  • edited July 2009
    Today I got my QSTARZ BT-Q818 receiver, I tested it and within a few seconds it got 8 sattelites so I'm happy :)
    It's now attached in the backside of my racer and I'm gonna test it on track the 3rd of August, I'll let you know how it worked ok :)
  • edited August 2009
    RC 1.30 beta on E71. I have notice the following issues.
    1) Whilst tracking daily commutes (same route) to work, if I display the laptimes afterwards, the time and datestamp displayed is that of the OPTIMUM lap, and not of the iduvidual lap.
    2) Not sure if 1.30b related, but also noticed in the summary screen, the traveled route duration is displayed as a negative e.g. -263:23:13(21MB).
  • aolaol
    edited August 2009
    1) Someone reported that issue before, I'm not sure whats going on, as I haven't seen that on my sessions. I'll try to figure it out.

    2) The time stamp is 32 bit integer and the accuracy is milliseconds. So a negative traveled route duration comes when you have a session that lasts for many days. I think it will disallow you from resuming soon.
  • edited August 2009
    Hope this helps
    1) I was running previous beta with 100% success before i upgraded. All data preserved OK. I've looked at other routes i've done since upgrade, and the problem does NOT show there.
    2) Possible that i left it on is good - possible ?
  • Hi, the problem 2) is expected and known. When you resume the session at multiple days, it will increment the time stamp too 24 hours worth of milliseconds. Not very common use case so probably not going to be fixed :). But the problem 1) is probably something that I need to try to reproduce.
Sign In or Register to comment.