Import GPS data from GoPro

I know the best way is to have an external GPS module, but given that a phone updates GPS positions at 1Hz and the newer GoPros at 10Hz it would be nice if there was a way to import that data.


  • This is already supported, please see the tutorial here:
  • I tried that with a file I copied to iCloud but that didn't work, now I tried with a sd adapter and this time it did work. Though it's imported as a new session, is there a way to have it imported to an existing session and just "improve" it?
  • edited June 2023
    If you want to combine more data, such as OBD-II to your sessions, you'll need to record it as a stand alone session... Then you'll need a good external GPS such as the RaceBox Mini. That will be a big improvement compared to the GoPro's GPS anyways.
  • Thing is I bought a GoPro 11 and had it on standard settings, didn't know RaceChrono didn't support 5k video transcoding. So I've been trying to find a way to gather all data into a new lap or add the the existing lap and then export an overlayed video.

    I'm using:
    - iPhone 13 Pro Max
    - GoPro Hero 11
    - OBDlink MX+

    I've almost managed todo the video in RaceRenderer but laptime is off and tbh gauges are not as synced/correct as in RaceChrono for some reason. For example, the gforce graph is all over the place in Race Renderer but the same data (from the gopro) looks great when I imported in in RC.
  • @Reine RaceChrono would support 5K exporting, but your iPhone does not...

    I cannot help you with RaceRender, but if you downscale your videos to 4K, or change the camera settings, you can export your videos with RaceChrono just fine:

    Probably future iPhones will do fine with 5K too.

    Also we have on our roadmap a feature to export the overlay only, so you could join it on a video editor on PC/Mac.
  • Seams like there is a way, maybe not through a native api though(?) but the Quick app does transcode from 5k to 4k when exporting a video.

    I just imported a 4k video and are trying to export but still, nothing. Not even the PIP from the iPhones built in camera shows up, just audio. What am I doing wrong?
  • edited June 2023
    AFAIK, Quik app uses the superior GoPro hardware to transcode the videos, not the iPhone's.

    The frame is black when the video codec or resolution is not supported. I cannot say without looking at the files what's wrong, but all the cases I've looked at, have been fixable with either downscaling the files or changing the camera settings.
  • Do you have a recommendation for how to easily rescale the original video into a format that works? I can do it on my Mac or iOS device, either is fine.
  • edited June 2023 This should work. If there's a problem let me know, and also send sample files.

    The latter line should work for you:

    ffmpeg -i GX010036.MP4 -vf scale=3840:2160 -c:v libx265 -crf 14 -c:a copy DOWNSCALED.MP4
  • This is the format of the video I'm using, looks downscaled too me?
  • Yes. But not all downscaled video files will work, although that file might work.
  • I'll fiddle around a bit more and see what I can come up with.
    Just to be sure though, should the PIP preview be visible or just black with the text PIP?
  • edited June 2023
    Yes, the PIP video should be visible on the exported video, the PIP text in black background should never appear on the exported video. If there's a problem with the main video, the PIP video might not appear either.

    On the overlay editor, the black box with PIP in it marks the location where the PIP video will appear once exported.
  • No I'm talking about the preview, before exporting.
  • edited June 2023
    On the overlay editor, the black box with PIP in it marks the location where the PIP video will appear once exported. The actual PIP video will not appear before exporting.
Sign In or Register to comment.