RaceChrono v7.2 beta



  • @fedemaisonnave Added to my TO-DO list. No promises on next beta but soon.
  • edited March 2021
    Uploaded new beta, and this one is going to production if all goes well.

    Change log for RaceChrono v7.2.2:
    - Added importing for AIM Data Logger files (.csv)
    - Added 5 Hz support for Transystem GL-770
    - Added new custom channel names
    - Fixed: Broken .fit file import from Garmin Fenix 6X Pro
  • @aol Thanks for the update! However, my GL-770 and v7.2.2 doesn't work properly. I mean, it can sync data as 1Hz, but not 5Hz update. My GL-770 is configured 5Hz update. I removed the app and reinstalled v7.2.2 beta, but nothing changed. I tried on another Android, but the result was the same. Any suggestions?
  • edited March 2021
    @Terry675 It should be first 1 Hz, and 5 seconds after first fix to satellites, turn to 5 Hz. So it's not immediate.
  • @aol Tried again, but still seems 1Hz update. I was able to record logs and laps properly, but the altitude and latitude data looks 1Hz update. When recording, I changed the view to the GPS detailed view, I saw "1Hz" on the top right corner. My phone is Android 7.0. This may be my device issue, so please do not spend a lot of time on this and go forward.
  • @Terry675 maybe try enabling the 5 Hz again? It could be my code, but it works perfectly on my device ...
  • @aol I reset the device and reinstalled the app and tried, but no change. When I used the other app like LightBlue and subscribed the LNS message, my phone receives several messages a second. I guess my GL-770 sends messages as 5Hz update.
  • @Terry675 Ok, I guess my code doesn't work properly. Which phone are you using?
  • @aol Sony Xperia Z5 sold in 2015 to 2016, updated to Android 7.0.
  • @Terry675 I've reviewed my code and cannot really find anything wrong with it. It switches to 5 Hz only if all the updates are received reliably. If there is an update missing regularly it does not do that. Any missing update might cause -0.2s to the lap time if it happens at the start line, as the intra-second updates do not have a time stamp. I believe it does not switch on your phone because some of the updates are not being received...
  • The v7.2.2 was a bit unfortunate so the v7.2.3 is the new release candidate.

    Change log for RaceChrono v7.2.3:
    - Removed redundant Rear brake position -channel
    - Fixed: Broken AIM import
    - Fixed: Always display video window when opening analysis from the video list
  • @aol Small updates. #1, for the GPS detailed view, Bearing and Speed look 5Hz update and others look 1Hz update. #2, All exported data doesn't have millisecond order. They are all like below. I'm not sure why my device doesn't work properly. Is this because the satellites you and I use are different? Anyway, thanks for your support. I will try this again when I go to tracks and ask my friends to try.

  • @Terry675 it's not the satellites, but maybe different firmware version on the device?
  • Thank you so much for adding support for importing AIM-exported-as-CSV format!
    I just imported a few sessions from people I know, and can now compare my laps against their reference laps.
  • @aol I bought it 4 years ago, so it could happen. I will ask my friends to try the new feature and get back to you. Anyway thank you for your support. This is super helpful!
  • @aol I don't know if this is the right topic, I've a couple of ideas / feature requests:
    - option to run the App in "immersive mode", with no system status bar: https://developer.android.com/training/system-ui/immersive. For now I've solved using the "System UI tweak" and adding RaceChrono App to the list of apps running in immersive mode
    - option to hide / move to floating button racechrono status bar during live sessions while driving.

    The aim of these two requests is to maximize the screen portion dedicated to timer/dashboards during the stint, since in any case while driving there won't be (or at least shouldn't be) any interaction. With new ultra-wide smartphones in landscape position the two bars are eating away a big percentage of the screen space while adding little to the experience (at least while driving).

    - Option to have a clear strong visual cue (i.e. screen flashing or changing color) at closing/starting of each lap: this might be used to sync external video in those cases the phone screen is in camera FOV, using the frame with the visual cue as reference. Maybe also an audio cue?

    Right now I'm using a YI 4k camera to record the sessions, sometime also a CamBox, and the most frustrating part of my experience is usually related to camera(s) start/stop and then video sync. YI is providing API to control the camera (https://github.com/YITechnology/YIOpenAPI), is this going to help in the future to add support for these cameras?
  • Hello,
    The 7.2.3 version works relatively well with my Tesla :)
    Some areas of improvement for this version:
    It is rather difficult to set the dashboard with the busCAN, it is necessary to be connected to the car and that it is running, which is not practical
    I would like to see a little more customization of the dashboard, temperature, voltmeter, different colors, etc.
    I had cuts during the acquisition after 5 10 minutes in a random way. I just updated the firmware 5.6.15 of OBDLINK LX, a priori it seems to work much better.
    Thank you for your work
  • edited March 2021
    THANK YOU for adding the import of Tesla track mode files!!!
    I have a question regarding the import of Tesla track mode file (.csv):
    When I import the file, how can I access the channels provided in the file (i.e. throttle position, brake pressure)? Can someone point me to a manual/tutorial for the use of imported data? Many thanks!
    Background: Up till now I used OBDLink LX and RaceChrono Pro for recording the session data. Now I have replaced the dongle by CANServer (from JWardell) and thus am relying on the Tesla provided track mode data.
  • @Martin_snr It creates a new session from the imported file. The channels should be available in graphs (you can enable it in the analysis settings), and for overlay (need to edit the overlay to show them). Where do you need help?
  • @Marcus54 Good to know that the firmware upgrade might improve it. I will work on the gauges in the near future, there will be more configurability etc.
  • edited March 2021
    @Jeby Full screen mode is on my TO-DO list. Unfortunately I'm using way too much of my time on maintaining the GoPro support, so I'm not that keen on adding new ones. I might change my mind of course, but right now I think my time is better used on other kinds of features on the app.
  • @aol When I import this file https://www.dropbox.com/s/j22xvjmr1gukgps/telemetry-v1-2021-03-27-12_56_08.csv?dl=0 I am unable to select any data channels, only GPS channels can be selected in analysis. I am using V 7.2.3 in german language.The track is Red Bull Ring, Austria. Tesla has SW 2020.48.12.1.
    Many thanks for any hints!
  • @Martin_snr The data channels seem to work just fine for your file as well. I'm able to scroll down the analysis settings for the "Data logger" channels. If you're adamant this is not the case for you, please send me screenshots or video capture to tracks(at)racechrono.com
  • @aol So I am sure it is an user error.
    This is what I have done:
    - Define a Tesla in profile with only internal GPS Receiver, no OBD-II reader, in other devices internal sensors set to on. In general expert settings enable experimantal devices.
    - import the tesla track mode file
    - a new session is created
    - open the session
    - select a lap (lap 2)
    - tap on settings - which only shows GPS-receiver channels and lap timer channels
    - go back to lap selection
    - tap on "Zusammenfassung" (i.e. overview?)
    - select data logger channels
    - no data for these channels is displayed
    See https://www.dropbox.com/s/5ugoliptwlyyigr/Tesla Track Mode Data Display.mp4?dl=0

    What am I missing? Thanks again!

  • @Martin_snr As far as I can tell you've done everything correctly, but I just cannot figure out why it does not show the data logger channels for you. Let's continue on email.
  • Just to close the case - it was a problem of the Android version.
  • edited March 2021
    @Martin_snr Yes, the data logger channels were not imported on Android 7.0 and earlier. Also there is a slight data resolution problem for other devices. And the AIM import suffers from the same problems. Will be fixed in next version. Thank you for the bug report!
  • edited March 2021
    I've just uploaded another beta. This time many many bug fixes.

    Change log for RaceChrono v7.2.4:
    - Support for GM VPW DPIDs
    - Improved: Engine load -channel is now available for custom channels
    - Fixed: Clunky Media permission usage on Android 10 and later
    - Fixed: Storage or Media permission was not properly requested when importing
    - Fixed: OBD-II data logging failed if reader power was lost at any point during a session (readers with Bluetooth LE connection only)
    - Fixed: AIM and Tesla Track Mode data logger channels not properly imported on Android 7.0 and earlier
    - Fixed: AIM and Tesla Track Mode import data logger channels resolution
    - Fixed: Possible end-of-session crash
  • Tested and confirmed support of GM VPW DPID support, or more specifically: multiple responses to a single PID request. I imagine this feature is useful for multiple vehicles outside of just VPW-based interfaces.

Sign In or Register to comment.