RaceChrono v7.2 beta



  • edited April 2021
    @aol Hi, I really appreciate you adding GL-770 5Hz support since v7.2.2. I've tried to get log from GL-770 by 5Hz with RaceChronoPro v7.2.3. However, it seems RaceChrono recognize that GL-770 was 1Hz mode as same as Terry675, even though the log in the GL-770 seems to have 5Hz data as follows:


    It seems that my GL-770 didn't fix satelite based on $GPGGA and $GPGSA. I suppose it would be the cause of 1Hz mode based on your comment on 13th March.

    On another note, the unit translation of RaceChrono seems not to work properly. For example, If I focus on the log above, the speed shall be around 21kph. However, If I see the same point via RaceChrono v7.2.3, it is over 50kph. Could you confirm it?

    For your information, my mobile phone is Android 7.0 and AQUOS L2 made by Sharp.
  • Hello,

    I found that there is a difference of 40m for the altitude between the GPS of the phone and the GPS of my car, this error remains constant over time.

    It is the altitude in Race Chrono that is wrong.

    Where I live, the altitude is 226m, the phone applications give the right altitude.

    My Tesla gives 226m Race Chrono indicates 265.99m...

    Today, I made a test with version 7.2.4, the BusCan acquisition is blocked for a duration of about 40s and works again during 30 or 40s etc ...

    I will reinstall version 7.2.3 and try again tomorrow.

  • edited April 2021
    @Marcus54 OK let me know about the CAN-Bus. I made some changes to the code, but tried to be careful :) I'll do some tests here too.

    The altitude can be different, I will check if I do something wrong there.
  • Hello,

    I reinstalled and tested version 7.2.3, it's OK

    I made a backup on the main menu.
    I uninstalled the 7.2.4 and installed the 7.2.3.
    I imported the backup.

    The preferences are not saved:( , the dashbord is not saved :( ...

    It took me 20 minutes to reconfigure everything.

    It would be good to have a full backup with the preferences :)

  • Yep, on my TO-DO to preserve vehicle profiles and overlays. So you're saying v7.2.4 CAN-Bus is broken and v7.2.3 is OK?
  • I did not retest the 7.2.4 today

    I can do a test tomorrow with the 7.2.3 to go and install the 7.2.4 on the way back and tell you.
  • @Marcus54 That would be perfect, thank you! I will be able to investigate it on Tuesday or Wednesday. Your tests would same me quite a bit of time.
  • After upgrading to 2.7.4, it worked.
    No problem with the CAN Bus
    If the phenomenon occurs again, I will inform you.l
    The GPS is still wrong ;)
  • Hello,

    I lost 3 times in a row the connection with the CAN bus. I reinstalled version 7.2.3 to check again...

    I found a bug in the equations on the latitude and longitude of the CAN bus GPS
    look at the screenshots...
    20210407-175458 20210407-175511

    20210407-175919 20210407-180156

  • edited April 2021
    @Marcus54 Please enable RaceChrono > Settings > Expert settings > Save device output. Then if you're recording a session, and there's multiple failures, just share the session to me (as .rcz) and I can see what went wrong.

    I cannot comment much on the screenshots, as there's so many things going on there, and I get confused. But at least:

    1) 10 ^ 5 is not what you expect it to be. It's bitwise XOR operation. I think you wanted pow(base, exponent): https://racechrono.com/support/equations

    2) Division of integer by integer results in integer, hence no decimals. It's a programming thing as sometimes you need to compute only with integers. Divide by decimal number (like 100.0) or with float(100) to get decimals. This is also documented in the above link.

    3) The 0.0000 is because the equation solver only displays four decimals, it's still using the full precision of 0.000001 for computing.
  • I'm going to try tomorrow with version 7.2.4 with Save device output.

    Is it me who doesn't interpret the equation correctly or is it a bug?
    Image1 Image2

  • @Marcus54 this is a bug it seems!
  • On a very small route there was no connection...
    I will try again this afternoon
    device_output_200.obd :

    <--11:48:11.877 OUT-->ATZ\r
    <--11:48:21.884 OUT-->\r
    <--11:48:31.891 OUT-->\r
    <--11:48:41.898 OUT-->\r
    <--11:48:50.079 OUT-->ATZ\r
    <--11:49:00.089 OUT-->\r
    <--11:49:10.098 OUT-->\r
    <--11:49:20.106 OUT-->\r
    <--11:49:25.225 OUT-->ATZ\r
    <--11:49:35.232 OUT-->\r
    <--11:49:45.240 OUT-->\r
    <--11:49:55.251 OUT-->\r
    <--11:50:00.764 OUT-->ATZ\r
    <--11:50:10.772 OUT-->\r
    <--11:50:20.781 OUT-->\r
    <--11:50:30.788 OUT-->\r
    <--11:50:39.886 OUT-->ATZ\r
    <--11:50:49.894 OUT-->\r
    <--11:50:59.899 OUT-->\r
    <--11:51:09.907 OUT-->\r
    <--11:51:15.127 OUT-->ATZ\r
    <--11:51:25.134 OUT-->\r
    <--11:51:35.143 OUT-->\r
    <--11:51:45.150 OUT-->\r
    <--11:51:50.470 OUT-->ATZ\r
    <--11:52:00.479 OUT-->\r
    <--11:52:10.487 OUT-->\r
    <--11:52:20.494 OUT-->\r
    <--11:52:25.936 OUT-->ATZ\r
    <--11:52:35.941 OUT-->\r
    <--11:52:45.947 OUT-->\r
    <--11:52:55.955 OUT-->\r
    <--11:53:04.883 OUT-->ATZ\r
    <--11:53:14.890 OUT-->\r
    <--11:53:24.898 OUT-->\r
    <--11:53:34.907 OUT-->\r
    <--11:53:40.111 OUT-->ATZ\r
    <--11:53:50.117 OUT-->\r
  • edited April 2021
    @Marcus54 Which OBD-II reader are you using? It has gone completely mute for some reason. I don't think it can be fixed at RC side... I think removal + pluging it in again is required
  • I use OBDink LX
    I have sent you by email another log where the acquisition stopped during the process.
  • edited April 2021
    @Marcus54 Same thing, the reader just goes mute after a while. No response at all.
  • Ok
    two possibilities:
    I will reinstall version 7.2.3, if it works without error, then RaceChron 7.2.4 is buggy.
    Or it's my OBDLINK, I have to ask a friend to lend me his to try.
  • @Marcus54 It looks like this is a problem with the OBD-II reader, so going back and fourth with the RC version is unlikely to help, unfortunately.

  • @aol you are right, it is the OBD that must have a defect. It is no longer under warranty. I disassembled it, found nothing suspicious, heated it up and re-soldered it....
    I regret that the OBDLink LX is so expensive... :(
  • @aol is there an advantage to take an OBDlink MX over the LX for the CAN bus?

  • Hello,
    I still have a problem :)
    I have a new OBDLink LX
    For it to work, I have to run "START", then do "STOP" and run it again...
    Here is what is in "device_output_200.obd" when the CAN bus does not work
    <--16:12:10.540 OUT-->ATZ\r
    <--16:12:11.543 IN -->\r\rELM327 v1.3a\r\r>
    <--16:12:11.543 OUT-->ATE0\r
    <--16:12:16.544 IN -->ATZ\r
    <--16:12:16.544 IN -->\r\rELM327 v1.3a\r\r>
    <--16:12:16.544 OUT-->ATZ\r
    <--16:12:17.545 IN -->ATE0\rOK\r\r>
    <--16:12:17.545 OUT-->ATE0\r
    <--16:12:22.546 IN -->\r\rELM327 v1.3a\r\r>
    <--16:12:22.546 OUT-->ATZ\r
    <--16:12:23.547 IN -->ATE0\rOK\r\r>
    <--16:12:23.548 OUT-->ATE0\r
    <--16:12:28.548 IN -->\r\rELM327 v1.3a\r\r>
    <--16:12:28.549 OUT-->ATZ\r
    <--16:12:29.549 IN -->ATE0\rOK\r\r>
    <--16:12:29.549 OUT-->ATE0\r
    <--16:12:34.550 IN -->\r\rELM327 v1.3a
    <--16:12:34.550 IN -->\r\r>
    <--16:12:34.551 OUT-->ATZ\r
    <--16:12:35.551 IN -->ATE0\rOK\r\r>
    <--16:12:35.554 OUT-->ATE0\r
  • @Marcus54 Thank you for the data sample. That is something that probably could be fixed in RaceChrono. Can you send also sample when it works?
  • <--13:35:38.096 OUT-->ATZ\r
    <--13:35:39.152 IN -->ATZ\r
    <--13:35:39.970 IN -->\r\rELM327 v1.3a\r\r>
    <--13:35:39.971 OUT-->ATE0\r
    <--13:35:42.001 IN -->ATE0\rOK\r\r>
    <--13:35:42.001 OUT-->ATL0\r
    <--13:35:42.009 IN -->OK\r\r>
    <--13:35:42.009 OUT-->ATSP0\r
    <--13:35:43.098 IN -->OK\r\r>
    <--13:35:43.098 OUT-->ATS0\r
    <--13:35:43.236 IN -->OK\r\r>
    <--13:35:43.236 OUT-->ATH1\r
    <--13:35:43.347 IN -->OK\r\r>
    <--13:35:43.348 OUT-->STM\r
    <--13:35:43.454 IN -->SEARCHING...\r
    <--13:35:43.492 IN -->2C102AB83\r
    <--13:35:43.530 IN -->2E1FC1FB1C998A60900313026464\r2D3B4001A0233D82261\r
  • @Marcus54 Ok, I will try to simulate this event, and fix the state machine in RaceChrono. Thank you for the feedback. I will notify you once it's fixed (or tried at least).
  • @Marcus54 I think this is fixed in v7.2.5. Available through beta group soon.
  • Just released new beta. OBD-II and CAN-Bus state machine is modified, so please see if they still work for you. Probably fixes the issue @Marcus54 is having.

    Change log for RaceChrono v7.2.5:
    - Added experimental support for Wit Motion BLE 5.0 IMU-sensor
    - Fixed: OBD-II connection initialisation failed sometimes (OBDLink LX for example)
  • Hello,

    It's installed, I'll tell you after several tries if it's OK
    You did not correct the bug on the longitude and latitude :)
  • edited April 2021
    @Marcus54 I do not "hot fix" small or cosmetic issues, they have to wait for major releases. I try to mitigate the risk of breaking something by fixing only urgent issues between the major releases.
  • Just released new beta. I think this will be the last one for v7.2 and I'll move on to v7.3 features next.

    Change log for RaceChrono v7.2.7:
    - Fixed: Crash when resolving device delay
    - Fixed: The last "in lap" was not displayed in the lap list
    - Fixed: Incomplete laps displayed as 0:00.00 in Analysis screen drop downs
    - Fixed: Missing rounding in live lap timer
  • Awesome fixes, thank you so much!

Sign In or Register to comment.